Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am a newer to Ubuntu. In my network manager the link Enable Mobile Broadband found unchecked.I can not enable it.So I can not connect my BSNL cdma 1x USB modem successfully.

share|improve this question
    
can you give a screenshot. –  Alaukik Feb 6 '11 at 6:50
    
I had this problem too, turned it my SIM was upside down ;) –  Gerhard Burger Aug 3 '13 at 8:11

1 Answer 1

The majority of the ubuntu distributions (even plain ubuntu), can handle Mobile Broadband modems with no problems. But in my experience with some modems (ZTE and Huawei) the availability to use the Broadband modem is based on the behaviour of the modem itself, which can be handled by the majority of the systems as both: broadband modem or usb CD-ROM. This is caused by the need of some vendors to include the drivers and applications in the same item.

In ubuntu you may try to eject the modem (which should be in the desktop or in your mounted devices area at: /media/) and after a few seconds, the item will be recognized as a modem and not a CD nor USB memory.

If everything happens as we expect, then you will be able to use your modem and get your connection.

REMEMBER: Just "eject" the device, DON'T unmount, which shall result in the unavailability of getting access to the device.

Good luck!

share|improve this answer
    
This behavior is solved by the usb-modeswitch packages, however installing for example Mobile Partner overwrites these settings. You can solve this by purging usb-modeswitch-data and then reinstalling it. –  Gerhard Burger Aug 3 '13 at 8:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.