Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I already had Ubuntu 12.04 LTS and Windows 7 on my hard drive, then I installed Backtrack on another partition. Now after installation when I reboot, the boot menu entry of Ubuntu 12.04 is gone. I only see entries for BT and Win 7. Ubuntu 12.04 is still there, as I can see it's file system intact.

Things I tried:

  1. Manually editing grub. But it seems /vmlinuz.img and /initrd.img are broken links. Manual editing grub files was a pain and didn't work.

  2. Used boot-repair to try to repair grub. Thought it worked but it's the same result at the end. I see BT and win 7 but not Ubuntu 12.04 entry.

Here is the boot-repair results file: http://paste2.org/p/2806011

share|improve this question
    
Exactly, which Grub configuration have you tried editing? The Ubuntu one or the Backtrack one? The bootloader now "belongs to" Backtrack (because it is the last installed OS), so you should edit Backtrack's configuration. –  Andrea Corbellini Jan 30 '13 at 13:37
    
Yes I went into the BackTrack Os and took root access and editing /boot/grub/grub.cfg and /etc/default/grub files from there. But its no use. I can't find the vmlinuz or initrd files for ubuntu I guess –  Pranshu Bongiovi Jan 30 '13 at 15:19
    
It appears you have broken packages. Look for apt-get in the boot-repair output: it is clearly telling you how to fix the dependency problems. Also, never ever edit /boot/grub/grub.cfg. As stated in the first lines of that file, all changes you make will be lost. –  Andrea Corbellini Jan 30 '13 at 15:36
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.