Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

ok so i've been reading some of the threads related to this issue, but i can't find a solution. i'm also very new to linux.

the situation: i used to have windows 7 on my hp and had a dual boot with ubuntu. i didnt want windows so when i booted the ubuntu installation from my usb, i installed it and everyting worked fine. somehow something went wrong when i did something with the partitions on the terminal. now when i boot my computer, it shows the above message. windows is uninstalled, i have no bootloader. when i try to install ubuntu and boot from my usb drive, it doesnt go to installation. instead it shows a black screen that reads "SYSLINUX 4.06 EDD 2012-10-23 Copyright (C) 1994-2012 H. Peter Anvin et al" and stays there.

any ideas? anything would be highly appreciated!

EDIT: here's what i tried from the terminal. and i was doing this to restore my usb drive back to its original state.

Restoring your USB key to it's original state using Linux:

A. First we need to delete the old partitions that remain on the USB key.

Open a terminal and type sudo su Type fdisk -l and note your USB drive letter. Type fdisk /dev/sdx (replacing x with your drive letter) Type d to proceed to delete a partition Type 1 to select the 1st partition and press enter Type d to proceed to delete another partition (fdisk should automatically select the second partition) B. Next we need to create the new partition.

Type n to make a new partition Type p to make this partition primary and press enter Type 1 to make this the first partition and then press enter Press enter to accept the default first cylinder Press enter again to accept the default last cylinder Type w to write the new partition information to the USB key Type umount /dev/sdx1 (replacing x with your drive letter) C. The last step is to create the fat filesystem.

Type mkfs.vfat -F 32 /dev/sdx1 (replacing x with your USB key drive letter)

source: http://www.pendrivelinux.com/restoring-your-usb-key-partition/

share|improve this question
1  
"somehow something went wrong when i did something with the partitions on the terminal."?? what are those something, please try to provide in detail information about your problem(what you have tried and what came out) by editing your question. Only then it can be answered. –  VRU Jan 30 '13 at 9:01
    
In addition to providing more information as @VRU says, please boot from the USB flash drive (the on you used to install Ubuntu) and run sudo parted -l, then copy all text from the Terminal and paste the output into your question. (You can format it with the <$> tool.) –  Eliah Kagan Jan 30 '13 at 9:18
    
when i boot from the usb, it loads the black screen with the "SYSLINUX 4.06 EDD 2012-10-23 Copyright (C) 1994-2012 H. Peter Anvin et al." then it just stays there and does nothing. if i let it boot regularly without the usb, it shows the "error: no such partition..." would it make a difference if i had an installation disc and run it from boot instead of the usb? –  darryl Jan 30 '13 at 9:25
    
When booting from the USB flash drive (same one used to install Ubuntu), press Enter after seeing that blank screen with a copyright message. –  Flimm Jan 30 '13 at 10:06
    
i've tried that but nothing happens. i think my input hardware are disabled at this screen. keyboard, mouse, and switches are all off. –  darryl Jan 30 '13 at 10:14
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.