Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using Ubuntu Quantal. I've recently updated and now my kernel is 3.5.0-23-generic.

After upgrade my NVIDIA driver stopped working... no problem! I re-installed it and now it works.

Now I started my Ubuntu, everything is just fine but:

  • Firefox keeps crashing (always! different timeframes, but always crashes, sometimes 10 sometimes 60 sec after run);
  • when I run apt-get install [something] I get this:

    $ sudo apt-get install curl
    Reading package lists... Done
    

When I run update Software Updater I get this:

Task cannot be monitored or controlled

The connection to the daemon was lost. Most likely the background daemon crashed.

Details

It seems that the daemon died.

If it helps, I can confess that I had like 2-3 hard reset on my PC recently if you think that could cause such problem. Entered recovery mode, selected fsck, waited a lot, I saw nothing, no change, no message, no progress, waited like 90 mins there, re-hard resetted.

What do you suggest? What could be the source of problem? What should I check/fix?

share|improve this question
add comment

1 Answer

I found out solution, these commands fixes everything:

sudo apt-get clean
sudo apt-get clean all
sudo rm -fr /var/cache/apt/*.bin

I saved above commands as an sh file and I always run it when it crashes again. Hope it helps you also.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.