Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This question already has an answer here:

There is Mac and Windows drivers only. I tried that tar.gz file Nothing happened. Usb cable not connected. Trying to print over wifi.

How can I use MX435 from Ubuntu?

share|improve this question

marked as duplicate by Takkat, Eric Carvalho, Fabby, Elder Geek, mikewhatever Feb 16 '15 at 23:02

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

the file you linked to did all the work! it is exactly what you needed. just open the terminal, navigate to the extracted folder, and run the file. worked for me:) – gilad hoch Apr 16 '13 at 8:23
Does wi-fi printing work? – Can Jun 9 '13 at 19:30
@Takkat I'm not convinced that this is a dupe as the MX435 isn't listed in the answer quoted. It may well work though. Can you confirm? I don't have one... – Elder Geek Feb 16 '15 at 14:11
@ElderGeek The list from the ppa answer (as was the answer prior to my edit BTW) is outdated. Unfortunately I have no idea where to get an updated list. Still, people can follow my answer below there to install the MX43x driver from Canon. It's always the same procedure for all Canon printers... hence I believe it is easier to maintain all these question in a master canonical question - I chose the one I linked to because it had most upvotes and views but added another answer for cases like this one. – Takkat Feb 16 '15 at 14:28
@Takkat Sorry, I missed that final answer. – Elder Geek Feb 16 '15 at 15:06
up vote 3 down vote accepted

According to that webpage you posted, there is a Linux driver. It's nice to find Linux support from manufacturers. The bad part is there's no easy installer provided.

In case you didn't know already, a .tar.gz file is a compressed directory in a file, somewhat like a .zip.

What you want to do first is extract the .tar.gz file. You can do this by double clicking the downloading cnijfilter-mx430series-3.70-1-deb.tar.gz file and selecting "Extract". After you extract the contents of the archive, navigate to the extracted directory. Inside you will find Double click it - Ubuntu will then ask whether you want to run the program or not. Say that you want to run the program in a terminal.

Tell us if it works, or if the terminal says anything unusual. If it says something along the lines of must be run as superuser or need root privileges, then you'll need to run it as root. For'd need to navigate to the directory in a terminal and run sudo

share|improve this answer
I tried with usb cable and with wifi, but nothing happened. It didn't work. By the way copier and scanner function works fine. – Can Jan 30 '13 at 5:50
Please give us the steps you took to come up with the conclusion of "it didn't work." We can't help you unless we know what you did (or more often, didn't) do. – Kupiakos Jan 30 '13 at 6:32
Sorry for latency. Its messed up right now. First I tried without driver, then tried with three different driver file. Now, I want to clear everything and start from stratch. How can I undo all of what I've done? By the way printer is okey. It worked with windows. – Can Feb 1 '13 at 22:30

The URL does contain a driver.

I also have an Canon MX 435 that i have had trouble installing on my Ubuntu 12-04.

After installing this driver the printer works so far.

share|improve this answer
Could you please elaborate how you installed it? – Braiam Aug 20 '13 at 18:59
It actually a long a messy story. I have a windows system as well that did the main installation and put the printer on the wireless network. After that I rand the installation script that is linked in the answer. After specifying the printer to we wifi (upon being asked) it detected it and seems to have installed proper drivers. – Mikael Fremling Aug 21 '13 at 7:04

Not the answer you're looking for? Browse other questions tagged or ask your own question.