Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Since installing Ubuntu 12.04 (switching from Windows, I'm new to Linux and Ubuntu) certain web pages, especially blog type web pages such as boingboing.net or non-blog pages such as offliberty.com, take 10 to 15 minutes to load. This problem occurs in Firefox, Opera and Chromium. As I mentioned, only some web pages are loading slowly, while 90% of the sites I visit load normally.

I have read around and tried fixes such as:

sudo dpkg-reconfigure resolvconf

This did not solve the problem.

Here are some specs on my computer: HP Pavilion dv6-6100, 6 GB RAM, AMD A8-3500M APU with Radeon(tm) HD Graphics × 4, Ubuntu 12.04, 64 bit

Other information plucked from my computer:

lspci | grep Network:

02:00.0 Network controller: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller (rev 01)

iwconfig:

lo        no wireless extensions.

eth1      IEEE 802.11abg  ESSID:"Bill"  
          Mode:Managed  Frequency:2.462 GHz  Access Point: 00:02:6F:60:35:A0   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off

eth0      no wireless extensions.

lsmod:

Module                  Size  Used by
snd_seq_midi           13324  0 
snd_rawmidi            30748  1 snd_seq_midi
snd_seq_midi_event     14899  1 snd_seq_midi
snd_seq                61929  2 snd_seq_midi,snd_seq_midi_event
snd_seq_device         14540  3 snd_seq_midi,snd_rawmidi,snd_seq
usb_storage            49198  1 
nls_utf8               12557  1 
udf                    94613  1 
crc_itu_t              12707  1 udf
btusb                  18332  1 
vesafb                 13844  1 
hp_wmi                 18092  0 
sparse_keymap          13890  1 hp_wmi
joydev                 17693  0 
rfcomm                 47604  12 
bnep                   18281  2 
bluetooth             180153  23 btusb,rfcomm,bnep
parport_pc             32866  0 
ppdev                  17113  0 
snd_hda_codec_idt      70795  1 
snd_hda_codec_hdmi     32474  1 
lib80211_crypt_tkip    17390  0 
snd_hda_intel          33773  5 
snd_hda_codec         127706  3 snd_hda_codec_idt,snd_hda_codec_hdmi,snd_hda_intel
snd_hwdep              17764  1 snd_hda_codec
snd_pcm                97275  3 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
uvcvideo               72627  0 
videodev               98259  1 uvcvideo
v4l2_compat_ioctl32    17128  1 videodev
snd_timer              29990  2 snd_seq,snd_pcm
wl                   3074895  0 
psmouse                97485  0 
serio_raw              13211  0 
snd                    79041  20
snd_rawmidi,snd_seq,snd_seq_device,snd_hda_codec_idt,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_timer
wmi                    19256  1 hp_wmi
fglrx                3264017  334 
k10temp                13166  0 
i2c_piix4              13301  0 
cfg80211              205774  1 wl
soundcore              15091  1 snd
snd_page_alloc         18529  2 snd_hda_intel,snd_pcm
lib80211               14381  2 lib80211_crypt_tkip,wl
rts_pstor             445241  0 
video                  19596  0 
hp_accel               25976  0 
lis3lv02d              19876  1 hp_accel
input_polldev          13896  1 lis3lv02d
mac_hid                13253  0 
lp                     17799  0 
parport                46562  3 parport_pc,ppdev,lp
pata_atiixp            13204  0 
r8169                  62154  0

dmesg | grep eth1:

[   12.840802] eth1: Broadcom BCM4727 802.11 Hybrid Wireless Controller 6.20.155.1  (r326264)
[   59.129120] eth1: IPv6 duplicate address fe80::422c:f4ff:fe05:4843 detected!
[   79.149757] eth1: IPv6 duplicate address fe80::422c:f4ff:fe05:4843 detected!
[ 1194.333758] eth1: IPv6 duplicate address fe80::422c:f4ff:fe05:4843 detected!
[ 4256.253774] ERROR @wl_notify_scan_status : eth1 Scan_results error (-22)
[ 4261.361829] eth1: IPv6 duplicate address fe80::422c:f4ff:fe05:4843 detected!
[11653.834679] eth1: IPv6 duplicate address fe80::422c:f4ff:fe05:4843 detected!
[14306.067886] eth1: IPv6 duplicate address fe80::422c:f4ff:fe05:4843 detected!
[22873.379725] eth1: IPv6 duplicate address fe80::422c:f4ff:fe05:4843 detected!

lshw -C network:

  *-network               
       description: Ethernet interface
       product: RTL8111/8168B PCI Express Gigabit Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:01:00.0
       logical name: eth0
       version: 06
       serial: 10:1f:74:0d:74:7c
       size: 10Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl8168e-3_0.0.4 03/27/12 latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:51 ioport:2000(size=256) memory:f0004000-f0004fff memory:f0000000-f0003fff
  *-network
       description: Wireless interface
       product: BCM4313 802.11b/g/n Wireless LAN Controller
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: eth1
       version: 01
       serial: 40:2c:f4:05:48:43
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=wl0 driverversion=6.20.155.1 (r326264) ip=192.168.0.126 latency=0 multicast=yes wireless=IEEE 802.11abg
       resources: irq:17 memory:f0200000-f0203fff

I appreciate any help that you are able to provide. Thank you.

UPDATE:

tracepath boingboing.net:

 1:  CliftonHP.local                                       0.200ms pmtu 1500
 1:  esr7750.esr7750                                       1.915ms 
 1:  esr7750.esr7750                                       1.397ms 
 2:  no reply
 3:  tge7-1.austtxf-er02.texas.rr.com                     10.229ms 
 4:  te0-10-0-2.austtxrdcsc-cr02.texas.rr.com             26.757ms asymm  6 
 5:  agg22.hstntxl3-cr01.texas.rr.com                     36.856ms 
 6:  ae-4-0.cr0.hou30.tbone.rr.com                        24.036ms 
 7:  ae-0-0.pr0.dfw10.tbone.rr.com                        31.194ms 
 8:  107.14.16.186                                        45.024ms 
 9:  vlan70.csw2.Dallas1.Level3.net                       83.710ms asymm 14 
10:  ae-71-71.ebr1.Dallas1.Level3.net                     74.836ms asymm 14 
11:  ae-14-14.ebr2.Chicago2.Level3.net                    86.226ms asymm 14 
12:  ae-1-100.ebr1.Chicago2.Level3.net                    84.725ms asymm 14 
13:  no reply
14:  ae-1-9.bar1.Toronto1.Level3.net                     123.745ms asymm 12 
15:  ae-3-3.car1.Toronto2.Level3.net                     142.218ms asymm 13 
16:  WBS-CONNECT.car1.Toronto2.Level3.net                102.478ms asymm 14 
17:  te-1-1.dist02.tor1.prioritycolo.com                  76.593ms asymm 15 
18:  te-1-2.dist01.tor1.prioritycolo.com                 124.297ms asymm 12 
19:  www.boingboing.net                                   69.041ms reached
   Resume: pmtu 1500 hops 19 back 243

tracepath offliberty.com:

 1:  CliftonHP.local                                       0.182ms pmtu 1500
 1:  esr7750.esr7750                                       2.246ms 
 1:  esr7750.esr7750                                       1.318ms 
 2:  no reply
 3:  tge7-1.austtxf-er01.texas.rr.com                     17.715ms 
 4:  tge0-10-0-3.austtxa-cr01.texas.rr.com                37.409ms asymm  6 
 5:  agg22.dllatxl3-cr01.texas.rr.com                     24.509ms 
 6:  ae-4-0.cr0.dfw10.tbone.rr.com                        45.939ms 
 7:  107.14.17.234                                        25.430ms 
 8:  66.109.9.214                                         24.930ms 
 9:  ae3.csr2.DAL2.gblx.net                               23.706ms 
10:  dal-2-6k.tx.us                                       19.514ms 
11:  dal-1-6k.tx.us                                       67.793ms asymm 10 
12:  no reply
13:  198.27.73.203                                       145.245ms asymm 20 
14:  rbx-g1-a9.fr.eu                                     139.555ms asymm 19 
15:  fra-1-6k.de.eu                                      172.028ms asymm 21 
16:  fra-5-6k.fr.eu                                      176.451ms asymm 20 
17:  sbg-g1-a9.fr.eu                                     163.379ms asymm 19 
18:  sbg-3b-6k.fr.eu                                     175.199ms asymm 20 
19:  ns399404.ovh.net                                    165.966ms reached
     Resume: pmtu 1500 hops 19 back 44

tracepath google.com:

 1:  CliftonHP.local                                       0.203ms pmtu 1500
 1:  esr7750.esr7750                                       1.838ms 
 1:  esr7750.esr7750                                       1.318ms 
 2:  no reply
 3:  tge7-1.austtxf-er02.texas.rr.com                     26.978ms 
 4:  te0-10-0-2.austtxrdcsc-cr02.texas.rr.com             42.558ms asymm  6 
 5:  agg22.hstntxl3-cr01.texas.rr.com                     49.949ms 
 6:  ae-2-0.cr0.hou30.tbone.rr.com                        30.256ms 
 7:  ae-0-0.cr0.dfw10.tbone.rr.com                        40.965ms asymm  8 
 8:  107.14.17.232                                        36.290ms asymm  7 
 9:  no reply
10:  no reply
11:  no reply
12:  no reply
13:  no reply
14:  no reply
15:  no reply
16:  no reply
17:  no reply
18:  no reply
19:  no reply
20:  no reply
21:  no reply
22:  no reply
23:  no reply
24:  no reply
25:  no reply
26:  no reply
27:  no reply
28:  no reply
29:  no reply
30:  no reply
31:  no reply
     Too many hops: pmtu 1500
     Resume: pmtu 1500

I also included the tracepath for google, which loads quickly.

The ping times were not out of the ordinary. I pinged the sites earlier while at work and, if anything, the ping times from this computer were lower than the ping times from my work computer, which loaded both of these pages in under 30 seconds.

share|improve this question
1  
do they contain flash contents? –  sazary Jan 30 '13 at 4:02
    
Some do. But I don't think boingboing.net does, for example. –  Clifton Jan 30 '13 at 4:41
1  
youtube.com uses flash, but it does not load slowly. –  Clifton Jan 30 '13 at 4:44
add comment

2 Answers

up vote 1 down vote accepted

Out of the question but, do you happen to be connected via 2 NICs on the same PC? I ask since I see:

[   59.129120] eth1: IPv6 duplicate address fe80::422c:f4ff:fe05:4843 detected!

In your log, so I would think that your wired connection got connected first, followed by your wireless connection, which gave that error since they are both connected to the same device. Might no be the case, just to make sure you check it out. Now with your answer:

This could be Ubuntu, but since, some pages are slow and others are not maybe you can do the following to check, if it is the site or you:

  1. Ping the site (This is the quickest way to see where the problem lies)

    ping boingboing.net

    ping offliberty.com

    FYI - I did this and got low latency but the pages for me opened like a minute or two after I tried to visit them. They are way too slow to open in Firefox, Chrome, Chromium, Opera and IE in Wine. I open other sites in less than 5 seconds.

  2. Trace your way to the site (Assuming the Ping was not enough)

    tracepath boingboing.net

    tracepath offliberty.com

    Another FYI - After doing this, at least with boingboing.net, the latency went really high on the jumps that said Chicago1, Miami1, Atlanta2. This might be my routing path but boy did it go up on those 3.

  3. If both of the above are positive, then try to use another computer (Same browser). For example, if you tested Firefox, then test Firefox in another computer. This can tell you if it is Ubuntu or the site.

  4. Make sure nobody else is using the internet connection when you are testing this (Happens a lot).

  5. Reboot or turn off/on the router and any other network device. Just to make sure since some devices need the occasional off and on to get them to work correctly again.

  6. Instead of using the wireless card, if possible, try to test the same connection with your wired card (If you can manage a cable to the router).

  7. Test the connection in different times of the day. Sometimes, using the connection a peak hours in your city / state will make your connection slow for some types of connections of course. This is also the case for sites, where, they have some peak hours or peak days where they get too many visitors and their connection goes down because of it. So try to test this also.

For the rest, as far as I can see, there is nothing wrong with your configuration. This might just be a moment that the pages are passing through, where they have high latency. For me, I think is not your problem but the sites problem, because when I did the tests I also did them in Windows and even called a friend in that moment. She told me the sites where slower than even facebook on a horrible day.

share|improve this answer
    
I added some more information above. –  Clifton Jan 31 '13 at 2:18
    
In addition, I am only connected wireless. I am not sure why the IPv6 duplicate address error would occur. Any ideas? –  Clifton Jan 31 '13 at 2:19
    
@Clifton - Updated answer to include 2 tests you could do but I have more confident this is not your fault, but the sites fault. –  Luis Alvarado Jan 31 '13 at 13:43
    
Sorry it has taken a long time to get back to this. I just bought a new browser and all of the web pages that were previously are now loading properly. So, your original assumption that there was nothing wrong with my computer or settings was correct! Thank you. –  Clifton Feb 13 '13 at 4:12
add comment

Have you tried installing Google Chrome instead? Although not open source, Google Chrome is the best choice for most users as it already includes nearly all the codecs and extensions most websites need to operate correctly.

http://www.howopensource.com/2011/10/install-google-chrome-in-ubuntu-11-10-11-04-10-10-10-04/

share|improve this answer
    
No. That never occurred to me. –  Clifton Jan 31 '13 at 2:20
    
Try it out. You will have a much better, faster, more stable web browsing experience overall. –  Jebeld17 Jan 31 '13 at 16:03
    
Tell me if this works :) –  Jebeld17 Jan 31 '13 at 16:03
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.