Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I would like to adjust my question slightly as I just updated one of my servers from 12.04 to 12.04.1 and am now seeing the same warnings on the upgraded server as well, so I am suspecting there is something with the kernel (which was upgraded) or one of the other packages.

So since there appears to be a lack of 'resolution' (googled for a quite a while to find something), can someone tell me how to suppress the warnings for open-vm-tools.

---[ original question below]---

I setup a new server today (VMware guest) and noticed in the /var/syslog the following warning entries:

(coming from open-vm-tools)

Jan 29 19:20:49 mail01 vmsvc[1168]: [ warning] [guestinfo] Error sending GuestMemInfo.
Jan 29 19:20:49 mail01 vmsvc[1168]: [ warning] [guestinfo] Failed to send vmstats.

These warnings are happening every 30 seconds. Oddly enough however VMware Infrastructure Client appears to be showing correct information regardless of the warnings. I have several other servers all running Ubuntu 12.04 (some upgraded from 10.04 even) that are running open-vm-tools, and none of them are producing this warning.

I have googled the error message but have come up with nothing as of yet. Any suggestions would be greatly appreciated. I do realize the alternative is to compile and install the tools directly from the server, but I would rather just use a package that has worked on other machines.

Host: VMware ESX Server 3i, 3.5.0, build 207095 (best I can do an HP Proliant DL580 G2) Guest / OS: Ubuntu 12.04.1 - 32bit

Any other information that I can provide, please let me know.

share|improve this question
up vote 1 down vote accepted

According to this post in the vmware forums, you have to modify to false in your vmx file:

[...] = "false"

Further explanations:

If you have this setting " = "true" this mean "Setinfo communication from tools to the ESXi host are being blocked".

Refer this Link for more detail about this parameter page 6

share|improve this answer
Thank you for your response, I have since moved to a different platform due to some unsupported hardware changes, but I hope this answer will help someone else encountering the same notice messages. – Aaron Murray Oct 11 '13 at 19:55

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.