Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
Unity doesn’t load, no Launcher, no Dash appears

I installed fresh (replaced Windows). I checked the "Update" and "Third-party" checkboxes during install. Everything going great, I entered my name/password. It seemed to install everything. But then after the FIRST reboot (it told me it needed to reboot after successful install) it an error message came up - very non-descript. Just asked me if I wanted to send report the error, and then it had another dialog to reboot. I rebooted again, and this time, I just get the desktop. At first I thought it was broken, but I could right click. So I created a folder, then got into the file structure. Then I could load some things, Firefox, etc. But obviously something went wrong. I know nothing about Ubuntu, BUT I am a pretty smart guy. I guessed that "Unity" is a big part of Ubunuty's OS. So, I found some terminal commands and, well I'll just paste below what I got and maybe someone (anyone?!) can help me! I LOVE Ubuntu so far! FYI - my the PC I am trying to use is a Dell OptiPlex, Pentuium 4 @ 2.7 GHz, 512MB RAM.

http://pastebin.com/6QMpU8WP

You can see there are several Unity errors. Maybe Ubuntu just win't work? :-(

What other linux options do I have to make an old PC, a simple fast web browser?

share|improve this question
    
Also, "Pentium 4 @ 2.7 GHz, 512MB RAM." is a really low-spec machine for Ubuntu 12.10 (if you're using that release). –  gertvdijk Jan 30 '13 at 0:03
    
I want to note that when I pressed Ctrl+Alt+F1, after logging in, I was getting this error every 30-45 seconds: (Buffer I/O Error on device fd0, logical block 0 - End request: io error , dev fd0, sector 0) This sounds like a HDD issue?I didn't FORMAT the drive before I installed, I just kinda assumed it would do that for me since it said I would lose my windows installation? Should I try erasing the partition, re-creating, etc? Also, I am going to try and borrow some RAM from another machine to add to it. I want Ubuntu/Unity on this machine, dammit. –  Nathan Smith Jan 30 '13 at 0:45
    
I tried the link and got the settings manager to "enable" Unity, but it's still the same. No unity. Can someone confirm, that I have "Gnome" working (the folders/windows/etc) but my problem is infact "unity" isn't loading (the sidebar, app launcher, HUD, etc) –  Nathan Smith Jan 30 '13 at 0:58
    
There was a segmentation fault in the errors you showed. This should not happen, even with insufficient RAM. So please report this bug. You can make Apport collect and submit the necessary technical information--but still be sure to read the bug reporting documentation first, and describe the problem thoroughly in the bug report you write in the web browser (which will come up automatically after Apport sends the data). –  Eliah Kagan Jan 30 '13 at 3:45
    
@EliahKagan I already installed Lubuntu, but I am MORE than glad to reinstall Ubuntu to see if the error will persist so I can file a bug report IF that will help the community. If this is some rare "one-off" occurrence I will probably focus my efforts on Lubuntu until I get a PC with specs better suited to handle Ubuntu. thx –  Nathan Smith Jan 30 '13 at 5:50
show 1 more comment

marked as duplicate by Uri Herrera, gertvdijk, Eric Carvalho, Eliah Kagan, Jorge Castro Jan 30 '13 at 4:57

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2 Answers

You could try Lubuntu, a version of Ubuntu that uses the LXDE desktop (instead of Unity) and runs on older systems with less resources (it only needs between 384-800 MB of RAM and will work with even less if you use the alternate installer).

It will still run all the same applications that the regular version of Ubuntu (with Unity) can run, except that the ones installed by default are different.

share|improve this answer
    
So I tried Uri Herrera's link. I was able to load that configuration manager. I enabled Unity and then the "required" frameworks/plugins that it said it needed. I rebooted and got the same thing (desktop, no Unity). So that is my issue, here, right? Unity isn't loading? I want to note that when I pressed Ctrl+Alt+F1, after logging in, I was getting this error every 30-45 seconds: (Buffer I/O Error on device fd0, logical block 0 - End request: io error , dev fd0, sector 0) This sounds like a HDD issue? –  Nathan Smith Jan 30 '13 at 0:40
    
@NathanSmith Yes, but why are you posting that as a comment to an answer about LXDE (the alternative to Unity)? This answer is a good suggestion for your older hardware, imo. –  gertvdijk Jan 30 '13 at 0:41
    
Sorry I don't know how to use this forum very well, I just found the "add comment" button, I was thinking I could reply to a specific comment, then your answer popped up with a text box below it and I got excited. –  Nathan Smith Jan 30 '13 at 0:46
    
Anyways, thanks for the suggestion, I'll definately have to try it out. Any idea what the buffer I/O Error is? The HDD was actually ugraded not too long ago in this box to a 160GB 7200 Barracuda. –  Nathan Smith Jan 30 '13 at 1:25
add comment

I think that reading what you posted is the answer: compiz (core) - Info: Unity is not supported by your hardware. Enabling software rendering instead (slow)..

Maybe you need to install third-party drivers if you have dedicated graphic card.

Look at login, if you can choose Fallback mode. Else try installing it or another interface, like XFCE. (http://www.psychocats.net/ubuntu/xfce)

share|improve this answer
    
so, It's a Dell computer. Third-party, meaning Dell? Or some obscure developer that might have written a driver for the Dell built-in graphics. Also, "look at login" - what does that mean? Ctrl+Alt+F1 and then type fallback mode, or type fallback mode into terminal? Sorry, I'm new to this, but I'm also a Web Developer so I know how to code. Still, I'm sure I sound 100% dumb right now. –  Nathan Smith Jan 30 '13 at 0:56
    
@NathanSmith, When you log out and have to put your password again, you can choose different desktop managers, if you have them installed. Maybe there you have a "fallback mode", for those who didn't like Unity. The Third-party software I said is in case you have NVidia or AMD graphics card which I doubt. I recommend you installing XFCE Desktop which is a Windows Manager lighter than Unity which uses much effects and consumes many resources. You would stick with Ubuntu, just another Desktop Manager. –  Jorge Jan 30 '13 at 1:00
    
Thanks for the help, I greatly appreciate it. So what would the difference be between Ubuntu/XFCE and Lubuntu/LXDE.. or maybe I should ask that in a simpler way - which combo would you go with? –  Nathan Smith Jan 30 '13 at 1:05
    
@NathanSmith Hi, I don't know LXDE, they're simply Desktop Managers, I use XFCE at my Work, I tried installing Unity and it was like 10 frames per second lol. You could Google them and see if you like theirs Menues and that stuffs. –  Jorge Jan 30 '13 at 1:37
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.