Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have 6 GB installed, which as a 64-bit OS, it should see, but it only sees 3.5 GB! How do I remedy this?

Output as requested:

seann@seann:~$ dmidecode --type memory | grep -E "(Size|Maximum.Capacity)"
    Maximum Capacity: 4 GB
    Size: 2048 MB
    Size: 1024 MB
    Size: 2048 MB
    Size: 1024 MB

seann@seann:~$ free -m
             total       used       free     shared    buffers     cached
Mem:          3513       3328        185          0        373       2083

-/+ buffers/cache:        870       2642

Swap:         3907          4       3903
share|improve this question
    
The whole point in switching to an x64 OS was to be able to use the full 6GB! –  Seann Jan 29 '13 at 23:37
1  
Welcome to Ask Ubuntu! We'll need more information to be able to answer your question. Please provide the output of sudo dmidecode --type memory | grep -E "(Size|Maximum.Capacity)" and free -m run from the terminal. Please edit your question to include this. –  gertvdijk Jan 29 '13 at 23:57
2  
Does your motherboard support more than 4 GB of ram? –  psusi Jan 30 '13 at 0:59
1  
@Seann Your mainboard may support this memory configuration, but it's not showing it to the OS: Maximum Capacity: 4 GB. My best bet: in your BIOS there's an option to limit the amount of memory displayed to your OS for compatibility reasons. Disable that. –  gertvdijk Jan 30 '13 at 1:48
1  
@gertvdijk It sounds like you may be able to post an answer. –  Eliah Kagan Jan 30 '13 at 4:01
show 3 more comments

1 Answer 1

up vote 0 down vote accepted

Limitation of the BIOS. Though it reports 6 GB installed, only 4 can be used. Dell does have a flash available but it's unclear as to weather or not it addresses the upper-limit issue described here. Still waiting for Dell to get back to me.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.