Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an installation of Ubuntu 12.04 on an SSD disk that I'm unable to boot after a kernel upgrade and a reboot. Additional things that might be a possible cause is that I did some cleanup (dpkg -r) of old unused kernels (a list that I selected manually from dpkg -l | grep linux-).

The following is what I can gather from booting a live system (that is, boot another operating system) and trying to access the disk.

The disk has two partitions, the first one is a small partition (sdb1) containing a /boot ext2 filesystem, and the second is LUKS encrypted, so I have opened it up using cryptsetup luksOpen /dev/sdb5 ssd. The new device is an LVM2 pv so I make that available with vgscan and then vgchange -a y. Now I have one LVM2 vg containing two logical volumes named foo-root and foo-swap. It is foo-root that contains my filesystem.

Now is when weird things start to happen. I try to mount the filesystem with mount /dev/mapper/foo-root /mnt which returns:

mount: unknown filesystem type 'jmicron_raid_member'

So I try to specify the filesystem type mount -t ext4 /dev/mapper/foo-root /mnt, and that works. I am happy to be able to access my data, but since I still cannot boot the disk I unmount the filesystem and continue exploring.

I run fsck.ext4 -f /dev/mapper/foo-root without errors.

At this point it seems that the problem is that the file system type is reported incorrectly. I run blkid -p /dev/mapper/foo-root and it returns:

/dev/mapper/foo-root: VERSION="55.72" TYPE="jmicron_raid_member" USAGE="raid"

A healthy ext4 filesystem would return UUID="along-uuid" TYPE="ext4".

I turn to google. It seems that dmraid could remove the erroneous RAID header with dmraid -Er but that does not work. Also dmraid -r returns:

no raid disks

For good measure, and a bit of alright-already-fix-it feeling, I try dmraid -x and dmraid -Er /dev/mapper/foo-root and neither helps in any way.

While accessing the filesystem I have tried various things like chrooting into it and rebuilding the initrd, rewrite grub to MBR (tried both sdb and sdb1), and making sdb1 bootable, among other things. Nothing seems to make the disk bootable again.

I am out of options. Any help is appreciated.

UPDATE: Running the command from @psusi comment:

0000000: 4a4d 4837 780a 4744 5851 7033 4d70 5136  JMH7x.GDXQp3MpQ6
0000010: 6c71 5056 4932 4f31 6c49 7155 7646 6359  lqPVI2O1lIqUvFcY
0000020: 414b 382f 7054 766f 5a32 5a57 754c 585a  AK8/pTvoZ2ZWuLXZ
0000030: 6e59 7746 5174 4b53 5656 686e 6230 4e4a  nYwFQtKSVVhnb0NJ
0000040: 4646 685a 506b 4155 3936 7335 4d69 2f65  FFhZPkAU96s5Mi/e
0000050: 4971 0a67 5346 6a59 4b43 4f2f 536f 5a5a  Iq.gSFjYKCO/SoZZ
0000060: 4855 3838 7231 2b6c 4137 4558 326c 704d  HU88r1+lA7EX2lpM
0000070: 6e6e 6a74 5463 4d63 2b6c 4959 3131 334c  nnjtTcMc+lIY113L
0000080: 6a6f 4b69 4346 4f56 4a42 3635 4641 4675  joKiCFOVJB65FAFu
0000090: 4457 626d 312b 5658 4c4b 4f64 7458 4a0a  DWbm1+VXLKOdtXJ.
00000a0: 4e5a 6136 6841 6b6a 5573 6553 6176 6e30  NZa6hAkjUseSavn0
00000b0: 735a 2b7a 5637 6f71 6561 564f 3566 6c7a  sZ+zV7oqeaVO5flz
00000c0: 3655 3458 6855 6373 4b6c 4d70 784a 494c  6U4XhUcsKlMpxJIL
00000d0: 612f 3152 6a46 6157 3563 3966 4e6b 4f31  a/1RjFaW5c9fNkO1
00000e0: 4150 6331 6f32 3368 6131 6a62 0a66 6653  APc1o23ha1jb.ffS
00000f0: 2f61 626e 474e 6b66 4559 787a 6e31 4e63  /abnGNkfEYxzn1Nc
0000100: 3157 7139 6b61 526a 6255 3339 4a69 314b  1Wq9kaRjbU39Ji1K
0000110: 3632 5765 6e51 4b6c 7567 3373 5742 4148  62WenQKlug3sWBAH
0000120: 7278 5854 5165 4634 346e 6534 3143 4d33  rxXTQeF44ne41CM3
0000130: 637a 592b 5668 3870 2f0a 4373 7562 5132  czY+Vh8p/.CsubQ2
0000140: 6847 3675 6470 3455 3850 5875 7132 5631  hG6udp4U8PXuq2V1
0000150: 465a 324b 7851 4842 5975 4e75 4354 6a49  FZ2KxQHBYuNuCTjI
0000160: 4866 474b 364f 342b 4851 3036 454a 4a4e  HfGK6O4+HQ06EJJN
0000170: 4578 5541 6b4b 546a 5070 7a53 5431 4432  ExUAkKTjPpzST1D2
0000180: 6e4b 506e 6730 0a37 5449 6d44 5478 4462  nKPng0.7TImDTxDb
0000190: 7879 514d 6e30 7761 7a5a 2f45 324a 7047  xyQMn0wazZ/E2JpG
00001a0: 4563 7337 6a6e 4c63 4138 6574 4356 7a4a  Ecs7jnLcA8etCVzJ
00001b0: 766e 454c 586e 6957 7868 4639 5038 4132  vnELXniWxhF9P8A2
00001c0: 645a 2f66 3277 7556 794f 344a 3731 4e59  dZ/f2wuVyO4J71NY
00001d0: 5357 6c0a 696b 7364 6a59 7665 7356 4b6f  SWl.iksdjYvesVKo
00001e0: 572b 376e 314f 6174 752b 6737 4c59 5732  W+7n1Oatu+g7LYW2
00001f0: 744e 574d 5a6a 765a 3459 5933 7756 696a  tNWMZjvZ4YY3wVij
share|improve this question
    
Please dump the last sector of the volume and add it to your question. You can do this with sudo dd if=/dev/mapper/foo-root bs=512 count=1 skip=$((`sudo blockdev --getsz /dev/mapper/foo-root` - 1)) | xxd –  psusi Jan 30 '13 at 1:12
    
I hope that the output means something to you @psusi cause it doesn't say me anything. :) –  holmb Jan 30 '13 at 20:50
add comment

1 Answer

up vote 0 down vote accepted

For some reason it looks like you have a jmicron raid signature at the end of the volume. You can erase it with:

sudo dd if=/dev/zero of=/dev/mapper/foo-root bs=512 seek=$((`sudo blockdev --getsz /dev/mapper/foo-root` - 1))

You should fsck the filesystem after to make sure nothing bad happened, and as always, have a backup.

share|improve this answer
    
This looks promising. I won't be able to test it until monday. Will report back when I've tried it. –  holmb Feb 1 '13 at 6:42
    
It works! Thanks alot. I'm now able to use my SSD again. The old HDD has been killing me. :) –  holmb Feb 6 '13 at 21:41
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.