Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
How to Install Broadcom / STA Wireless card (BCM43XX)
Can’t connect to any wireless connection after updating

Well my wireless card worked just after install, and after a reboot no wireless card was detected, so I can't connect wirelessly. The results of lspci -nn are:

01:00.0 Network controller [0280]: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller [14e4:4727] (rev 01)

And here is iwconfig:

eth0      no wireless extensions.

lo        no wireless extensions.

rfkill list all:

0: hci0: Bluetooth
Soft blocked: no
Hard blocked: no
1: samsung-wlan: Wireless LAN
Soft blocked: no
Hard blocked: no
2: samsung-bluetooth: Bluetooth
Soft blocked: no
Hard blocked: no

lsmod:

    Module                  Size  Used by
    parport_pc             32689  0 
    ppdev                  17074  0 
    rfcomm                 46620  12 
    bnep                   18141  2 
    ext2                   72881  1 
    snd_hda_codec_hdmi     32049  1 
    snd_hda_codec_realtek    78048  1 
    coretemp               13401  0 
    kvm_intel             132760  0 
    kvm                   414071  1 kvm_intel
    ghash_clmulni_intel    13221  0 
    aesni_intel            51038  0 
    cryptd                 20404  2 ghash_clmulni_intel,aesni_intel
    aes_x86_64             17256  1 aesni_intel
    snd_hda_intel          33492  3 
    snd_hda_codec         134213  3 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_intel
    snd_hwdep              17699  1 snd_hda_codec
    snd_pcm                96668  3 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
    snd_seq_midi           13325  0 
    snd_rawmidi            30513  1 snd_seq_midi
    snd_seq_midi_event     14900  1 snd_seq_midi
    snd_seq                61555  2 snd_seq_midi,snd_seq_midi_event
    snd_timer              29426  2 snd_pcm,snd_seq
    snd_seq_device         14498  3 snd_seq_midi,snd_rawmidi,snd_seq
    i915                  520621  3 
    drm_kms_helper         49113  1 i915
    drm                   288721  4 i915,drm_kms_helper
    i2c_algo_bit           13414  1 i915
    psmouse                95595  0 
    snd                    78921  16 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
    btusb                  22475  0 
    uvcvideo               76750  0 
    videobuf2_core         32852  1 uvcvideo
    soundcore              15048  1 snd
    videodev              120310  2 uvcvideo,videobuf2_core
    videobuf2_vmalloc      12861  1 uvcvideo
    samsung_laptop         14533  0 
    serio_raw              13216  0 
    mei                    40691  0 
    bluetooth             209249  22 rfcomm,bnep,btusb
    videobuf2_memops       13405  1 videobuf2_vmalloc
    video                  19336  2 i915,samsung_laptop
    lpc_ich                17062  0 
    microcode              22804  0 
    joydev                 17458  0 
    mac_hid                13206  0 
    snd_page_alloc         18485  2 snd_hda_intel,snd_pcm
    lp                     17760  0 
    parport                46346  3 parport_pc,ppdev,lp
    hid_generic            12541  0 
    usbhid                 46987  0 
    hid                   100411  2 hid_generic,usbhid
    uas                    17845  0 
    usb_storage            48839  0 
    r8169                  61651  0 

I'm not sure what all of the above means, but it was posted to help solve another wireless card issue so I thought it would be helpful to post it here.

Any help in getting my wireless working would be greatly appreicated! :)

share|improve this question
add comment

marked as duplicate by gertvdijk, Eric Carvalho, Eliah Kagan, Jorge Castro, hhlp Jan 30 '13 at 10:06

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2 Answers

up vote 0 down vote accepted

You need to install third-party drivers from Broadcom. Even if you want to use b43 (although your card is not in the list of supported and tested devices, this may require forcing b43 to work on that card, I don't know), you'd need firmware from broadcom.

Ubuntu has a page with instructions to handle Broadcom wireless cards. So do other Linux distros, namely Arch Linux, which also describes the state of Broadcom wireless cards.

In short, you need to install the bcmwl package. (The page also lists broadcom-sta, which is the name used on my (non-Ubuntu) distro, I am not sure of what the difference is, but that does say to install bcmwl...)

share|improve this answer
    
The (proprietary) Broadcom drivers should be in System Settings > Hardware > Additional Drivers. Just a sidenote, I installed b43 after using the official drivers for a while and the signal strength isn't nearly as good as with the Broadcom drivers. Unless you need monitor mode functionality or something, stick with the official ones. –  mtdevans Jan 29 '13 at 18:57
1  
Seems that the driver just wasn't being started on startup. Soon as I ran 'sudo modprobe brcmsmac' the card came into action. Thank you very much for your assistance. –  Phillip Macdonald Jan 29 '13 at 20:08
add comment

Please get a temporary wired ethernet connection and open a terminal and do:

sudo apt-get install linux-headers-generic
sudo apt-get install bcmwl-kernel-source
sudo modprobe wl

Your wireless should then be working. I don't believe b43 and firmware is optimal for 14e4:4727.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.