Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

A serious issue cropped up just now, I removed my 32bit 12.04 and installed 12.10 64bit version. I followed Creating an EFI partition given at UEFI

Now my system wont boot without my bootable USB stick connected.. It automatically goes into Press F12 to enter boot menu mode without the USB stick

With the usb connected I get this boot screen, with one extra option saying Install Ubuntu OEM (for manufacturers only) Again same UEFI link as above

Ubuntu is installed fine as I can see the 3 partitions I created while Installing UEFI boot partition, / and /home and also this confirms that I have ubuntu 12.10 and Windows 7

enter link description here

And the following image shows the partitions I have, I have made a mistake by creating 2 swaps, I'll rectify it later

enter image description here

Here's my fstab entries

/etc/fstab

The output from bootrepair:

What's going wrong where ?? Please help me..

FYI: I also tried to install 64bit 12.04 when it released, but had problems of windows not being listed in Grub bootloader.

share|improve this question
1  
I included that log into your post, which you can do yourself in the future :-) - So its time to remove the comment too. –  guntbert Jan 29 '13 at 21:33
add comment

1 Answer

You don't have a proper EFI installation; there are several things wrong with it. First, though, consider this: It looks as if you're dual-booting with Windows, and Windows is clearly installed in BIOS mode. If you intend to keep booting Windows from this disk, I strongly recommend against attempting an EFI-mode installation of Linux. Instead, I recommend booting a Linux recovery disk in BIOS/legacy mode and re-installing GRUB 2. That should get Linux booting in BIOS mode, and you should be able to dual-boot Windows in BIOS mode.

If you don't care about booting Windows, or if you want to convert it to boot in EFI mode, you'll have to correct some things about your installation:

  • The partition table uses the Master Boot Record (MBR) rather than the GUID Partition Table (GPT) system. Although some EFI-based computers seem to be able to boot from MBR disks, some have problems with this. I don't know what percentage have problems with this, but the vast majority of EFI installations use GPT. If you intend to convert Windows to boot in EFI mode, converting the disk to GPT is an absolute requirement. You can do an in-place conversion with GPT fdisk, which is available in the Ubuntu repositories as gdisk.
  • You have no EFI System Partition (ESP). It appears that your /dev/sda8 was intended as an ESP, but it has the wrong type code. On an MBR disk, an ESP has a type code of 0xEF. On a GPT disk, it's identified via a type code of EF00 in gdisk or by a "boot flag" in parted or GParted. (Note that the libparted "boot flag" means something entirely different on GPT disks than on MBR disks. Your /dev/sda8 does have an MBR "boot flag," but that does not identify it as an ESP!)
  • It's unclear if you've registered your EFI version of GRUB with the EFI. If not, you need to do this with the efibootmgr utility, as in:

    efibootmgr -c -p 8 -l \\EFI\\ubuntu\\grubx64.efi -L Ubuntu

    The installer should set this up, and you can type efibootmgr -v to see the existing entries to see if you've already got one.

  • There may be other things you'll need to do to get the system booting in EFI mode, but they're likely to be highly system-specific. The Ubuntu Boot Repair tool can do some of them automatically, but given the mixed nature of your current installation, I'm not sure I'd trust it until you've gotten things more in line with a standard installation.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.