Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Samsung laptop which received a bump yesterday. After that, the system doesn't load the Windows (Vista), the screen remains black, doesn't boot.

I burn a LiveCD with Ubuntu to try to back up my data, but was unsuccessful. My hard drive has two partitions: the main (C:) which has Windows and all my documents, and one another (D:) which I have some documents and files. This partition (D:) is right, I can mount it. I did a back up that files were there, really I want to recover 2 folders (30 mb, no more).

But I really want to do back up some folders which are in C: partition, but when a I try to mount I receive the message:

Error mounting /dev/sda2 at /media/ubuntu/C06E17086E16F6BE: Command-line `mount -t "ntfs" -o "uhelper=udisks2,nodev,nosuid,uid=999,gid=999,dmask=0077,fmask=0177" "/dev/sda2"   "/media/ubuntu/C06E17086E16F6BE"' exited with non-zero exit status 13: ntfs_attr_pread_i: ntfs_pread failed: Input/output error  
Failed to read NTFS $Bitmap: Input/output error  
NTFS is either inconsistent, or there is a hardware fault, or it's a
SoftRAID/FakeRAID hardware.  

In the first case run chkdsk /f on Windows then reboot into Windows twice. The usage of the /f parameter is very important! If the device is a SoftRAID/FakeRAID then first activate it and mount a different device under the /dev/mapper/ directory, (e.g. /dev/mapper/nvidia_eahaabcc1). Please see the 'dmraid' documentation for more details.

and now, I do not know how to proceed.

Please, does somebody know how to do?

share|improve this question
1  
I think the answer to this question might be what you're looking for superuser.com/questions/193899/… –  Chris Wilson Jan 29 '13 at 17:36
add comment

1 Answer 1

up vote 0 down vote accepted

The disk you have got damaged.

You can try to save the data from it by running fsck on the partition (according to your post this would be ntfsfix /dev/sda2 {the ntfsfix being the "fsck for windows"). Answer any question that appears. (You most probably need to accept / press enter everywhere.)

After this mount it as you wanted the first time, and pray that your files be intact.

share|improve this answer
    
Hello, I wento to the terminal, and I have writen: sudo ntfsfix /dev/sda2 the message given was: Mounting volume..Ok Proccessing of SMFT and SMFTMirr completed successfully Checking the alternate boot sector..OK NTFS volume version is 3.1 NTFS partition /dev/sda2 was proccessed successfully I didn't accept any questions....Now what can I do? I came back to the Ubuntu desktop and tried to open the partition and showed the same error. Do I have to restore before the laptop? Thanks you for your reply –  Carlos Jan 29 '13 at 18:26
    
I'm afraid that this indicates that your disk became unusable. Also you might want to wait with accepting an answer and see if it actually helps before an accept. –  Wolfer Jan 29 '13 at 18:57
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.