Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Following a power outage in the neighbourhood two days ago, I restarted my computer and everything seemed fine.
However, I cannot access the internet anymore. The computer is a desktop and is connected to the web using a wired connection.
I tried reinstalling the network from the recovery menu in GRUB and selecting "Network" "Enable networking", but when I do this fsck starts and simply stalls. Any other way for me to re-enable networking? Thanks

share|improve this question
    
How did you connect to the net? (I mean through the network manager gui or through pppoeconf or something else?) Also could you post the output of ifconfig? –  Wolfer Jan 29 '13 at 17:43
2  
Have you considered checking whether there are problems with your ISP? Or with some hardware that connects your network to the ISP? Do you have networking (as in you just can't access the internet) or the network device stopped working? –  njsg Jan 29 '13 at 18:17
    
if it stalls in fsck then it seems like a problem with your hard drive, not networking. can you run the system in normal mode (i mean not recovery mode)? –  sazary Jan 29 '13 at 19:49
    
I know for sure this is not a problem with my ISP, since my internet access is fine on the same computer when I boot under Windows. I also know that the hard has no major malfunction since the system still runs fine in normal mode and the applications work normally. Only internet access is interrupted. I will try the other solutions tonight when I get home. Thanks. –  trudeal Jan 29 '13 at 19:54
    
@guntbert Thanks for the suggestion. This solved my problem! –  trudeal Feb 1 '13 at 1:09

1 Answer 1

fsck starting and stalling looks like a known bug in recovery.
Go to "root shell" and type mount / -o remount,rw. Then exit that shell and try "Enable Networking" again.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.