Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I prefer to use VLC because it never gives me problems while Totem does. I'd like to uninstall Totem, so all file associations point to VLC. However I still want to have video thumbnails in Nautilus.

share|improve this question
    
Have you tried sudo apt-get remove totem? –  ulidtko Feb 5 '11 at 9:52
    
Yes, but that doesn't solve the "still have video thumbnails in Nautilus" part :) –  sashoalm Feb 5 '11 at 12:20
add comment

3 Answers 3

up vote 2 down vote accepted

It's not actually uninstalling it but if you do sudo cp /usr/share/applications/totem.desktop ~/.local/share/applications/totem.desktop and then gedit ~/.local/share/applications/totem.desktop and add a new line Hidden=true the desktop will completely forget totem exists. It will no longer be used for file associations and will not show up in the menus but the thumbnailer should continue to function.

share|improve this answer
    
This works for me, I wanted to uninstall totem mostly because I didn't know of a better way to completely remove it from the file associations. –  sashoalm Feb 13 '11 at 10:08
add comment

I think you have to leave the totem-common Install totem-common package installed you can remove all of the other totem packages and still have thumbnails.

After that check the preview tab in nautilus preferences Nautilus Preferences Dialog

As you can see I have everything set to local and anything over 10MB won't get one. Meaning most videos apart from a few family videos. You can change this up to 4GB.

If you have changed this and still no joy then try deleting your ~./thumbnails folder go to your home folder and press ctrl+h to show the hidden files and folders. After this log out or restart nautilus and after a few minutes it should start to rebuild the thumbnail cache (ps good way to get some drive space back). If this doesn't work or nothing happens hours after restarting nautilus then a re-installation of Nautilus may be required. To do this open up Synaptic package manager and search for nautilus right click on the checkmark next to the package and selet re-install from the menu.

Hope this helps.

share|improve this answer
    
totem-common seems installed even after I remove totem but still no thumbnails. Here's the output from the console: sudo apt-get remove totem ... sudo apt-get install totem-common Reading package lists... Done Building dependency tree Reading state information... Done totem-common is already the newest version. 0 upgraded, 0 newly installed, 0 to remove and 4 not upgraded. –  sashoalm Feb 5 '11 at 12:36
add comment

Try installing ffmpeg thumbnailer.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.