Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have problem with optirun command on Ubuntu 12.10 installed on notebook DELL M6600. In the BIOS I have enabled Optimus technology. I have two graphics:

lspci -vnn | grep '\''[030[02]\]'
  • Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0126] (rev 09) (prog-if 00 [VGA controller])
  • NVIDIA Corporation GF104 [Quadro 4000M] [10de:0e3b] (rev a1) (prog-if 00 [VGA controller])

I have installed nvidia drivers:

dpkg -l | grep nvidia

ii  boinc-nvidia-cuda                         7.0.27+dfsg-5ubuntu0.12.04.1               amd64        metapackage for CUDA-savvy BOINC client and manager
ii  bumblebee-nvidia                          3.0.1-3~quantalppa2                        amd64        nVidia Optimus support using the proprietary NVIDIA driver
ii  nvidia-common                             1:0.2.71.1                                 amd64        transitional package for ubuntu-drivers-common
ii  nvidia-cuda-doc                           4.2.9-1ubuntu1                             all          NVIDIA CUDA and OpenCL documentation
ii  nvidia-cuda-gdb                           4.2.9-1ubuntu1                             amd64        NVIDIA CUDA GDB
rc  nvidia-current                            304.64-0ubuntu1~quantal~xup1               amd64        NVIDIA binary Xorg driver, kernel module and VDPAU library
ii  nvidia-experimental-310                   310.14-0ubuntu1                            amd64        Experimental NVIDIA binary Xorg driver, kernel module and VDPAU library
rc  nvidia-settings                           304.64-0ubuntu1~quantal~xup1               amd64        Tool for configuring the NVIDIA graphics driver
rc  nvidia-settings-experimental-310          310.14-0ubuntu1                            amd64        Tool for configuring the NVIDIA graphics driver
ii  nvidia-settings-updates                   304.51-0ubuntu2                            amd64        Tool for configuring the NVIDIA graphics driver

When I try this:

 optirun -vv -debug glxspheres

I got:

[  912.342326] [DEBUG]Reading file: /etc/bumblebee/bumblebee.conf
[  912.497379] [DEBUG]optirun version 3.0.1 starting...
[  912.497472] [DEBUG]Active configuration:
[  912.497560] [DEBUG] bumblebeed config file: /etc/bumblebee/bumblebee.conf
[  912.497600] [DEBUG] X display: ebug
[  912.497660] [DEBUG] LD_LIBRARY_PATH: 
[  912.497694] [DEBUG] Socket path: /var/run/bumblebee.socket
[  912.497724] [DEBUG] VGL Compression: proxy
[  912.734313] [INFO]Response: No - error: [XORG] (EE) No devices detected.

[  912.734376] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) No devices detected.

[  912.734399] [DEBUG]Socket closed.
[  912.734447] [ERROR]Aborting because fallback start is disabled.
[  912.734477] [DEBUG]Killing all remaining processes.
share|improve this question
add comment

3 Answers

up vote 2 down vote accepted

I think I got the same problem. When I intalled bumblebee, it did not recognise my discreet card. Looking for this problem, I found that Ubuntu uses the key nvidia instead of nvidia-current to refer to the drivers of nVidia.

So try this:

Make a backup of the file /etc/bumblebee/bumblebee.conf

  • sudo cp /etc/bumblebee/bumblebee.conf /etc/bumblebee/bumblebee.conf.backup

(for example)

Edit that file (use the editor you want, for example gedit):

  • sudo gedit /etc/bumblebee/bumblebee.conf

Go down to the section [driver-nvidia].

There, change the value of

  • KernelDriver=nvidia-current

to

  • KernelDriver=nvidia

and

  • Module=nvidia-current

to

  • Module=nvidia

Save the file and reboot.

Now try again:

  • optirun -vv -debug glxspheres

If you get your same error, restore the configuration file:

  • sudo cp /etc/bumblebee/bumblebee.conf.backup /etc/bumblebee/bumblebee.conf

Have Luck.

share|improve this answer
add comment

One time I had the exact same problem, IIRC I didn't have bbswitch installed. Do you have it? If not, install, reboot and try again. If you have suspended your notebook, I also had problems with using optirun after suspending/hibernating, try rebooting the machine.

share|improve this answer
    
When I try to install bbswitch, DELL not boot properly. I can't reach login sreen. I am very confused. I had to renstall 'bumblebee' to get to previous state. –  jafan Jan 29 '13 at 19:33
add comment

My solution to this problem was adding my card into /etc/bumblebee/xorg.conf.nvidia configuration file.

Uncomment the line:

BusID "PCI:01:00:0"
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.