Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

since two days I can't connect to facebook any more. All other pages work. I tried it from Firefox as well as from Chromium (both on ubuntu 12.10). The strange thing is, that it is working on Windows.

I also already changed the MTU to 1492.

I run curl, too:

* About to connect() to facebook.com port 80 (#0)
*   Trying 66.220.152.19...
* connected
* Connected to facebook.com (66.220.152.19) port 80 (#0)
> GET / HTTP/1.1
> User-Agent: curl/7.27.0
> Host: facebook.com
> Accept: */*
> 
* additional stuff not fine transfer.c:1037: 0 0
* HTTP 1.1 or later with persistent connection, pipelining supported
< HTTP/1.1 302 Found
< Location: https://facebook.com/
< Content-Type: text/html; charset=utf-8
< X-FB-Debug: nvdzA4R/GF2tDj/80QDgq5VV2OM8KYeRDz2Zm9mwdxM=
< Date: Tue, 29 Jan 2013 16:24:50 GMT
< Connection: keep-alive
< Content-Length: 0
< 
* Connection #0 to host facebook.com left intact
* Closing connection #0

Has anybody an idea, what it could be?

Thank you!

share|improve this question

closed as too localized by dobey, ImaginaryRobots, gertvdijk, Jorge Castro, hhlp Jan 30 '13 at 10:03

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1  
What does "can't connect' mean? What happens in the two browsers when you try to load facebook.com? Is only facebook.com affected? What happens if you try facebook.org? Can you bring up a terminal and try ping -c1 facebook.com? What ip-adress, if any, is in the result? Why have you been changing the MTU? There's very rarely any reason to meddle with such details of the network stack for non-professionals. –  user50849 Jan 29 '13 at 15:50
    
Facebook.com, facebook.org and facebook.de are bringing a timeout. The result of the ping is the IP 69.171.237.24, (which should be right, or?). I changed the MTU because I found a similar problem here: link –  Lukas Jan 29 '13 at 16:08
    
Hmm, what if you curl -v facebook.com in the terminal? Might be a lot of text, please update the question, instead of posting as comment. –  user50849 Jan 29 '13 at 16:23
2  
the curl output says the connection worked, status 302 means you got redirected to the https version. This is a problem with chromium/firefox, not your network. –  ImaginaryRobots Jan 29 '13 at 16:47
1  
This shows the connection is working; as @ImaginaryRobots said you've just been redirected to HTTPS. Now run curl -v https://facebook.com and paste the output –  jackweirdy Jan 29 '13 at 16:53

1 Answer 1

up vote 1 down vote accepted

Note: This would remove all the custom settings, bookmarks, history, cookies, saved passwords and co.

  • Open a terminal and run rm -rf ~/.mozilla
  • Open Firefox and go to Facebook again.

This might help: http://chat.stackexchange.com/rooms/7296/discussion-between-alen-and-michael-tanner, which is a chat link from the question: Facebook not working on Ubuntu 12.04.

share|improve this answer
2  
Won't this remove custom settings, bookmarks, history, cookies, saved password & co.? Isn't there a less destructive solution? –  Andrea Corbellini Jan 29 '13 at 16:49
    
Ofcourse, it would. –  green7 Jan 29 '13 at 16:49
    
wouldn't it be better to specify it explicitly then? ;-) –  Andrea Corbellini Jan 29 '13 at 17:05
    
There! In your words :) –  green7 Jan 29 '13 at 17:10
    
Hey, thank you, that helped! Do you know why that problem occours? I had also in mind, that it coult be connected with the https. But other https sites worked, too. –  Lukas Jan 29 '13 at 20:49

Not the answer you're looking for? Browse other questions tagged or ask your own question.