Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I run aptitude install ia32-libs it gives me this output (on Pastebin due to length constraints of StackExchange).
The install fails, as it leaves ia32-libs in a Not Installed state. All other solutions that it suggests to me are pretty useless too.

I've tried purging every ppa and reverting to default repositories of Ubuntu, but it didn't help.

Could you help me?

this is the output of apt-get install ia32-libs-multiarch. as it seems, apt-get tries to be less "smart" compared to aptitude, and it prints a more comprehensive output.
i tried to manually install one of the packages that it recalls, gstreamer0.10-plugins-good:i386, but it lead to installing libpixman-1-0:i386, and as you can see there, it basically tries to remove everything that is installed on my machine!
what's going on?

share|improve this question
If you have multiarch enabled, you shouldn't need to install ia32-libs or ia32-libs-multiarch. These two packages are kept just for 'historical' reasons (i.e. avoid broken dependencies). – Andrea Corbellini Jan 29 '13 at 16:44
i need to install these packages to run android development tools on my system. btw, how can i enable multiarch? and what is it? – sazary Jan 29 '13 at 19:32
@sazary I think you should read this answer for more about what Multi-arch is, why you don't want to install ia32-libs nowadays and what the alternative is. For the same reason: avoid aptitude for the time being - it's not working with Multi-arch yet: LP Bug #831768 - aptitude cannot handle conflicts with multiarch enabled – gertvdijk Feb 1 '13 at 21:41
@gertvdijk thanks for the article. btw, when i tell apt-get to install ia32-libs it automatically tries to install ia32-libs-multiarch. – sazary Feb 2 '13 at 3:57

You have to use this command: sudo aptitude install ia32-libs-multiarch, or better: sudo apt-get install ia32-libs-multiarch

share|improve this answer
It is, but the user asked for the right command. ;) The incriminated package's name is ia32-libs-multiarch and not ia32-libs. – Frantique Jan 29 '13 at 14:29
Let's give the freedom to everyone to use what he likes. ;) Who are we to tell people what pkg manager to use? :) – Frantique Jan 29 '13 at 14:38
right you are :-) – guntbert Jan 29 '13 at 14:41
doesn't work. nearlly the same output. – sazary Jan 29 '13 at 19:59
check out its output – sazary Jan 29 '13 at 20:12
up vote 0 down vote accepted

lastly i found this solution, mainly by chance, since i don't know why this problem had occured in first place, and i don't know why this solution works. but it works.
for example i found that my system has difficulties installing libpixman-1-0 package. then this is what i must do:
1. open /var/lib/dpkg/status. this is a sensitive file, so consider taking a backup from it beforehand.
2. search for the line that is Package: libpixman-1-0. after this line, there should be a paragraph like this:

Package: libpixman-1-0
Status: install ok installed
Multi-Arch: same
Priority: optional
Section: libs
Installed-Size: 582
Maintainer: Ubuntu Developers <>
Architecture: amd64
Source: pixman
Version: 0.24.4-1
Depends: libc6 (>= 2.14)
Pre-Depends: multiarch-support
Description: pixel-manipulation library for X and cairo
 A library for manipulating pixel regions -- a set of Y-X banded
 rectangles, image compositing using the Porter/Duff model
 and implicit mask generation for geometric primitives including
 trapezoids, triangles, and rectangles.
Original-Maintainer: Debian X Strike Force <>  

3. in my own case, there were multiple entries for this package, in fact two. find them all.
4. simply delete them!
5. now apt-get doesn't know anything about this package, and it assumes that it is not installed (though it is). so it thinks that any package that is dependent on libpixman-1-0 is now broken. you should run apt-get -f install. it simply tells apt-get to fix broken dependencies. in our case, it installs libpixman-1-0 properly.
6. now test again apt-get install ia32-libs-multiarch. if it doesn't install properly, find the other packages like libpixman-1-0 that are misbehaving. do these things for them too.

but how did i find that libpixman-1-0 is problematic? if you run apt-get install ia32-libs-multiarch it complains about some packages that are needed but can't be installed. try to install them by apt-get and it will tell you why they can't be installed. this way you can find the root of problem.

share|improve this answer
i should say again that i don't know what all of these means! so if you're going to apply this howto, beware that this may do some harm to your system that i'm not aware of! – sazary Feb 1 '13 at 20:55

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.