Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an Acer Aspire One KAV60. Beginning with 11.10 through 12.10, every version of Ubuntu causes the screen to stay blank after I open the lid. The only way I can get out of the problem is a hard restart. Hitting the esc key or left mouse button causes the screen to flash on for a fraction of a second and I can see a working display when this happens, but I can't keep it on with any keystroke combination I have tried.

I have turned off all power saving options, disabled standby, and selected do nothing when the lid is closed. Nothing has any effect.

To avoid this problem (which often results in lost data if the lid is accidently closed before a program save) I have to stay with 11.04 even though it is now no longer supported.

There seem to be some bug fixes shown for this problem, but they specify non-intel graphics cards. My laptop has an on-board intel video driver. Under any circumstances, there seems to be no timeframe for fixing the bugs that are shown to exist.

Any suggestions will be greatly appreciated.

share|improve this question

3 Answers 3

There is a post from devilkin that solved my problem, here is the solution:

It requires the ACPI VIDEO module loaded.


Create the file /etc/acpi/lidswitch.sh with these lines (don't forget to chmod +x on it):

#!/bin/sh
# /etc/acpi/lidswitch.sh
# Re-activates the screen when the lid is opened again

LID_STATE="/proc/acpi/button/lid/LID/state"
LCD_STATE="/proc/acpi/video/VID1/LCD/state"

grep -q open $LID_STATE

if [ $? -eq 0 ]; then
    echo 0x80000001 > $LCD_STATE
fi


Then put these lines in /etc/acpi/events/lidswitch (lidswitch not being a folder, but a file without a file extension):

# /etc/acpi/events/lidswitch
# This is called when the lid is closed or opened and calls
# /etc/acpi/lidswitch.sh for further processing.

event=button[ /]lid
action=/etc/acpi/lidswitch.sh

Extra help:

(1) Use gedit to create these files. So open up Terminal, then type in 'sudo gedit' (without quotes) and copy and paste the lines above.

(2) Use nautilus to apply the "chmod +x" property to the file. To do this, open up Terminal, then type in 'sudo nautilus' (without quotes) and the navigate to etc, acpi, then right-click on lidswitch.sh, navigate to Properties, then Permissions, then Allow executing file as program, then click Close.

share|improve this answer

Create the file /etc/acpi/lidswitch.sh with content (don't forget to chmod +x on it):

#!/bin/sh
# /etc/acpi/lidswitch.sh
# Re-activates the screen when the lid is opened again

LID_STATE="/proc/acpi/button/lid/LID/state"
LCD_STATE="/proc/acpi/video/VID1/LCD/state"

grep -q open $LID_STATE

if [ $? -eq 0 ]; then
    echo 0x80000001 > $LCD_STATE
fi

Place a new script inside this folder?--->>/etc/acpi/events/lidswitch

Then put this in /etc/acpi/events/lidswitch:

# /etc/acpi/events/lidswitch
# This is called when the lid is closed or opened and calls
# /etc/acpi/lidswitch.sh for further processing.

event=button[ /]lid
action=/etc/acpi/lidswitch.sh
share|improve this answer

I had the same issue even in Ubuntu 10.04, but,

With me, changing the value from "blank" to "nothing" in the lid close options solved the issue.

There is some difference with the two options though.

With "blank" if I close the lid, video playback stopped (No audio of the video playback in mplayer while the lid was closed), however pure audio playback still continued (e.g. in Rhythmbox). If i now open the lid, i only get a blank screen and the only way out was to press the power button. this will cause the system to suspend and then i have to again wake it up to get a display.

With "nothing", both audio and video files continues to play even with the lid closed. And when i open the lid, i see the normal display again:)

To automatically set the values from blank to nothing, i did this in terminal:

sudo gconftool-2 -t string /apps/gnome-power-manager/buttons/lid_ac -s "nothing"

sudo gconftool-2 -t string /apps/gnome-power-manager/buttons/lid_battery -s "nothing"

To do this manually, open the gconf-editor by hiting alt+F2 and then enter gconf-editor. Then, browse to apps->gnome-power-manager->buttons and change the values of lid_ac and lid_battery manually

Hope it helps in the newer versions also.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.