Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

dmesg shows stranges massages. Last year I tried mythtv but it didn't work for me and thus I removed it again.

Today I saw that dmesg shows this messages:

[   16.047679] init: mythtv-backend main process (2489) terminated with status 127
[   16.047707] init: mythtv-backend main process ended, respawning
[   16.060100] init: mythtv-backend main process (2503) terminated with status 127
[   16.060124] init: mythtv-backend main process ended, respawning
[   16.071027] init: mythtv-backend main process (2514) terminated with status 127
[   16.071061] init: mythtv-backend respawning too fast, stopped

But mythtv is definitely not installed

~$ dpkg --get-selections | grep mythtv
mythtv-backend                  deinstall
mythtv-common                   deinstall
mythtv-database                 deinstall
mythtv-frontend                 deinstall
mythtv-transcode-utils              deinstall

This post seems to solve a similar problem (with juju instead of mythtv). Obviously the corresponding remedy would be to delete /etc/init/mythtv-backend.conf

Can I do so safely? Is there anything else I can/should do (maybe similar to running stop juju-jon-sample-file-storage in the previous mentioned post)?

share|improve this question
    
What's the output of file /etc/init.d/mythtv-backend /etc/logrotate.d/mythtv-backend && sudo updatedb && locate mythtv? (The middle part may take a while after you put in your password, that's OK.) –  Eliah Kagan Jan 29 '13 at 11:45
    
I can't give that a shot anymore since I already purged everything. Thanks anyway –  justfortherec Jan 29 '13 at 13:00
    
That's OK--there's no need to investigate where the files are if you were able to remove them. –  Eliah Kagan Jan 29 '13 at 13:04
add comment

1 Answer 1

up vote 4 down vote accepted

dpkg --get-selections should return nothing for packages that are not installed. The fact that it is returning something is a symptom that there are parts of the package that have not been removed.

If you try --list instead of --get-selections, you'll see the reason why the package is not fully removed. In your case, you should see rc near mythtv-backend, meaning that there is still Residual Configuration for the package.

Files inside /etc are considered configuration files and are not removed automatically when removing a package. To remove residual configuration, you need to purge the package:

apt-get purge mythtv-backend

This is the correct way of removing all configuration files, including the ones in /etc/init.

share|improve this answer
    
Oh Thanks. I only tried apt-get purge mythtv which obviously didn't work. No everything is fine. Thanks –  justfortherec Jan 29 '13 at 13:00
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.