Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Ubuntu 12.04 64-bit, GEFORCE GT440, 2 19" VGA monitors with 1280x1024 support. Installed proprietary Nvidia drivers.

% nvidia-xconfig -v

nvidia-xconfig:  version 304.43  (buildmeister@swio-display-x86-rhel47-13)  Sun Aug 19 21:19:28 PDT 2012
  The NVIDIA X Configuration Tool.

  This program is used to manipulate X configuration files, specifically to enable NVIDIA X driver functionality.

  Copyright (C) 2005 - 2010 NVIDIA Corporation.

Now I try to connect the second monitor to videocard via VGA-DVI adapter. It connects only with resolutoin 640x480. Monitor is correct: it displays 1280x1024 when connected to VGA directly. Adapted is correct: tested on Windows machine, it accept 1280x1024.

As I understand, I have troubles in my X11 settings. Here is my xorg.conf:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 304.43  (buildmeister@swio-display-x86-rhel47-13)  Sun Aug 19 21:19:28 PDT 2012


Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GT 440"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Any help will be appreciated. I've spent a lot of time trying to run it with normal resolution.

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.