Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This question already has an answer here:

Running apachectl -k restart gives:

/usr/sbin/apachectl: 87: ulimit: error setting limit (Operation not permitted)
apache2: Could not reliably determine the server's fully qualified domain name, using for ServerName
httpd not running, trying to start
(13)Permission denied: make_sock: could not bind to address
no listening sockets available, shutting down
Unable to open logs
Action '-k restart' failed.
The Apache error log may have more information.

This is what I am getting while restarting the server. How can I fix this?

share|improve this question

marked as duplicate by qbi, belacqua, Eric Carvalho, Eliah Kagan, RolandiXor Feb 7 '13 at 0:33

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

did you run that command as root ? – bodhi.zazen Feb 5 '13 at 17:27

To restart apache, please use:

sudo service apache2 restart
share|improve this answer
up vote 0 down vote accepted

Finally I got the answer / reason..! Acutally, the reason for not restarting here, something other. it is ..

The default port for my apache2 here is 80, and is being used by some other process/server called some "xyzserver". then Apache tried to start on the same port,but it could not able start. later I found the that, and I killed that process then restarted apache2. It successfully working now.

I tried in the way

sudo service apache2 restart

I got the same error i.e., the way I regularly use.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.