Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am connected to a LAN network and wireless network. Both provide access to internet.

Sometimes when the internet on LAN is not working, the browser simply throws an exception instead of switching to Wireless. (Wireless is on and local peer computers on wireless are connectible).

Apparently it is giving more priority to LAN. How do I increase the priority of Wireless or set it as an automatic fall back?

share|improve this question
1  
I suspect that the problem is that Network Manager does not detect that the problem exists: maybe the link is up but the wlan connection is not. If the ethernet link goes down, then the wireless one is chosen automatically --- at least it happens on my laptop if I disconnect the cable. There is a launchpad request to add priorities to NM, maybe you can dig some more there: bugs.launchpad.net/ubuntu/+source/network-manager/+bug/366780 –  Rmano Jan 29 '13 at 22:12
    
Do you know if all connections on the LAN fail, or could it be something like a DNS lookup issue? Unrelated to your question, maybe check the DNS preferences for each connection. If different, and you want LAN to work better, maybe try switching to what wireless has –  Dolan Antenucci Jan 31 '13 at 21:32
    
As a workaround, I would try creating a script, that runs every several seconds and tries to ping e.g Google. On failure 'ifconfig eth0 down' so that NM knows to switch to the other network. Ugly, isn't it? –  Vorac Apr 2 '13 at 14:20

2 Answers 2

Go to system settings -> Network -> wired

Then click on options, select IPV4 tab, and click on routes.

Finally enable the Use this connection only for resources of its network

This way Ubuntu will use only Wireless for accessing the Internet

share|improve this answer

It's not the browser's fault. Routing is done by the kernel as configured by NetworkManager.

NetworkManager only monitors the local link in deciding whether or not to enable a connection, and it always prioritizes wired over wireless. It doesn't monitor whether "the Internet" is reachable via connections.

To force NM not to use the wired connection (because it is connected to a malfunctioning router) open the Connection Editor via the indicator and delete it from the list. Or unplug the Ethernet cable.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.