Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running apache2 on ubuntu linux. I dont know what is the reason but unable to access my localsite which is placed on var/www/xyz. xyz is the site root folder here. when I try only localhost it is showing "It works". but If I try with the site like localhost/xyz.It is showing the following error. It was worked fine till yesterday, but today I got this problem.

Not Found
The requested URL was not found on this server. 

could anybody please help me in this regard.

I tried restarting I got this error

sudo /etc/init.d/apache2 restart
 * Restarting web server apache2                                                                                                                apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName
apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName
(98)Address already in use: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
Action 'start' failed.
The Apache error log may have more information.

Thanks in advance

share|improve this question
    
Check the apache error logs in /var/log/apache2 and tell us what it says so you can get some help! –  djthoms Jan 29 '13 at 5:48
    
::1 - - [28/Jan/2013:10:40:04 +0530] "OPTIONS * HTTP/1.0" 200 126 "-" "Apache/2.2.22 (Ubuntu) (internal dummy connection)". This is what it contains in the first line –  Chella Jan 29 '13 at 5:54
    
Copy the relevant information from the error.log file in that directory. You might see something like [Mon Jan 28 10:46:00 2013] [notice] caught SIGTERM, shutting down –  djthoms Jan 29 '13 at 5:56
    
Yes it is there. What should I do now. [Mon Jan 28 19:25:45 2013] [notice] caught SIGTERM, shutting down –  Chella Jan 29 '13 at 6:03
    
@djthoms: Will you please tell me what to do –  Chella Jan 29 '13 at 6:06

1 Answer 1

up vote 2 down vote accepted

I resolved the issue..! It was due to, some other process using the same port 80. so it was unable to run. I found out process and killed and restarted the apache server.

It is working now.

share|improve this answer
2  
Please mark this as accpted answer, when its possible. –  saji89 Jan 29 '13 at 7:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.