Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently installed ubuntu 12.10 on my Macbook Pro mid 2012 alongside Mountain Lion using rEFIt boot. I am having trouble connecting to wireless network. When I click the internet icon at the top of the menu bar, no networks are shown and when I try to manually connect through edit connections, it doesen't work. I did not instal any drivers for anything, but the trackpad (even the two finger scrolling works) , brightness keys, volume keys and keyboard illumination led brightness works. So.. I am guessing it came with some drivers.

Here are my results of some things I typed into terminal

  1. nm-tool

    State: disconnected
    
    Device: eth0 -----------------------------------------------------------------  
    Type:              Wired  
    Driver:            tg3
    State:             unavailable
    Default:           no
    HW Address:        A8:20:66:2A:05:23
    
    Capabilities:
    Carrier Detect:  yes
    
    Wired Properties
    Carrier:         off
    
  2. sudo lshw -C network

    PCI (sysfs)  
    
    *-network               
    
    description: Ethernet interface
    
    product: NetXtreme BCM57765 Gigabit Ethernet PCIe
    
    vendor: Broadcom Corporation
    
    physical id: 0
    
    bus info: pci@0000:01:00.0
    
    logical name: eth0
    
    version: 10
    
    serial: a8:20:66:2a:05:23
    
    capacity: 1Gbit/s
    
    width: 64 bits
    
    clock: 33MHz
    
    capabilities: pm msi msix pciexpress bus_master cap_list ethernet physical tp 10bt 
    
    10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
    
    configuration: autonegotiation=on broadcast=yes driver=tg3 driverversion=3.123 
    
    firmware=57765-v1.37 latency=0 link=no multicast=yes port=twisted pair
    
    resources: irq:16 memory:a0400000-a040ffff memory:a0410000-a041ffff
    
    *-network
    
    description: Network controller
    
    product: BCM4331 802.11a/b/g/n
    
    vendor: Broadcom Corporation
    
    physical id: 0
    
    bus info: pci@0000:02:00.0
    
    version: 02
    
    width: 64 bits
    
    clock: 33MHz
    
    capabilities: pm msi pciexpress bus_master cap_list
    
    configuration: driver=bcma-pci-bridge latency=0
    
    resources: irq:17 memory:a0600000-a0603fff
    

Thank you, any help is great, I am only 14 and I just need a bit of help.

Also, if this doesn't work, will an older version of Ubuntu or a different Linux work?

share|improve this question
add comment

1 Answer 1

up vote 2 down vote accepted

Please get a temporary wired ethernet connection. Open a terminal and do:

sudo apt-get install linux-firmware-nonfree
sudo modprobe -r b43 && sudo modprobe b43

It should now be working.

share|improve this answer
    
that didnt work!!!!!!!!!!!!!!!!!!!!!!!!!! –  Skyler 440 Feb 1 '13 at 2:59
    
Please run and post: dmesg | grep b43. The pipe symbol | is on the right side of my US keyboard on the same key with \. –  chili555 Feb 1 '13 at 22:35
    
i got it to work on ubuntu 12.04 instead of 12.10 –  Skyler 440 Feb 4 '13 at 2:17
    
Glad it's working! –  chili555 Feb 4 '13 at 15:04
    
Thanks but it's not that important but my keyboard backlight won't work now –  Skyler 440 Feb 4 '13 at 15:16
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.