Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm all for using default shortcuts for basic task — you'll avoid conflict and know the default keys when using another Ubuntu computer.

One exception is the minimize window keyboard shortcut: Ctrl+Alt+0. This only works with numpad zero (not wise for an OS optimized for netbooks) and not for me as I don't have a numpad.

Whenever I set a custom shortcut either via keyboard settings or dconf they only last one reboot.

The only answer I found involves completely resetting Unity which I would very much like to avoid as I have a lot of custom settings — and I don't even know if it works for 12.10.

Does anyone have a solution for this?

Thanks!

share|improve this question

2 Answers 2

up vote 1 down vote accepted

There seems to be a lot of similar questions, and the source of the problem appears to be a regression bug in 12.04 and 12.10. It looks like it was fixed for 13.04 (I haven't tested).

See my answer in Custom keyboard shortcuts are reset. How can I make them set permanently? for a workaround. It requires setting up a little "autostart" script that sets your shortcuts... not ideal but at least it works.

PS: I can also confirm the "autostart" script solution works here with Compiz Config Settings Manager installed (I'm not messing with replacing my whole Compiz configuration though, just have it installed to toggle a few things).

share|improve this answer
2  
I'm using 13.10 and it still isn't fixed... –  Halil Özgür Feb 4 at 15:13
    
I'm using 14.04 and it still isn't fixed... –  king_julien Jul 6 at 12:17
    
I'm using 13.04 and it still isn't fixed... horrifying –  lisak Jul 8 at 11:35

Okay, think a may have found a solution after this has been bugging me for month. After uninstalling Compiz Config Setting Manager my minimize window key bindings have survived 3 reboots. (Another reason not to install CCSM unless you absolutely have to.)

I'll check if there's a bug report on this.

Meanwhile uninstalling CCSM is a solution for similar problems ...

share|improve this answer
1  
Hmm, well shortcut was reset again so CCSM isn't all there is to it. Theory: CCSM caused the shortcut to be reset after each session. On top of that system updates causes the shortcuts to be reset occasionally ... –  user76766 Feb 4 '13 at 15:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.