Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've run sudo apt-get install -f from which I received the error: (after typing 'y' to give it permission to install libreoffice-common)

Errors were encountered while processing:
/var/cache/apt/archives/libreoffice-common_1%3a3.6.2~rc2-0ubuntu4_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

I am running 12.10.

I also ran the commands:

sudo apt-get clean
sudo apt-get autoremove
sudo apt-get autoclean

Then I tried

sudo apt-get remove libreoffice-common libreoffice-core libreoffice-ogltrans

and received the error:

Package 'libreoffice-common' is not installed, so not removed
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 libreoffice-base-core : Depends: libreoffice-core (= 1:3.6.2~rc2-0ubuntu4) but it is not going to be installed
 libreoffice-calc : Depends: libreoffice-core (= 1:3.6.2~rc2-0ubuntu4) but it is not going to be installed
 libreoffice-draw : Depends: libreoffice-core (= 1:3.6.2~rc2-0ubuntu4) but it is not going to be installed
 libreoffice-emailmerge : Depends: libreoffice-core but it is not going to be installed
 libreoffice-gnome : Depends: libreoffice-core (= 1:3.6.2~rc2-0ubuntu4) but it is not going to be installed
 libreoffice-gtk : Depends: libreoffice-core (= 1:3.6.2~rc2-0ubuntu4) but it is not going to be installed
 libreoffice-impress : Depends: libreoffice-core (= 1:3.6.2~rc2-0ubuntu4) but it is not going to be installed
 libreoffice-math : Depends: libreoffice-core (= 1:3.6.2~rc2-0ubuntu4) but it is not going to be installed
 libreoffice-pdfimport : Depends: libreoffice-core but it is not going to be installed
 libreoffice-presentation-minimizer : Depends: libreoffice-core but it is not going to be installed
 libreoffice-presenter-console : Depends: libreoffice-core but it is not going to be installed
 libreoffice-writer : Depends: libreoffice-core (= 1:3.6.2~rc2-0ubuntu4) but it is not going to be installed
 mythes-en-us : Depends: libreoffice-core but it is not going to be installed or
                         openoffice.org-core (>= 1.9) but it is not installable or
                         language-support-writing-en but it is not installable
 python-uno : Depends: libreoffice-core (= 1:3.6.2~rc2-0ubuntu4) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
share|improve this question

2 Answers 2

The fact that you are experiencing this problem is a bug, and can be reported.

Try removing LibreOffice completely:

sudo apt-get remove libreoffice-common libreoffice-core libreoffice-ogltrans libreoffice-base-core libreoffice-calc libreoffice-draw libreoffice-emailmerge libreoffice-gnome libreoffice-gtk libreoffice-impress libreoffice-math libreoffice-pdfimport libreoffice-presentation-minimizer libreoffice-presenter-console libreoffice-writer mythes-en-us python-uno openoffice.org-debian-menus libreoffice-help-en-gb libreoffice-help-en-us libreoffice-help-zh-cn

Then check that everything seems to be working normally:

sudo apt-get install -f

Try installing SL (it's a small joke package that's harmless):

sudo apt-get install sl

This solution is based on this discussion.

share|improve this answer
    
The following packages have unmet dependencies: libreoffice-core : Depends: libreoffice-common (> 1:3.6.2~rc2) but it is not going to be installed libreoffice-ogltrans : Depends: libreoffice-common but it is not going to be installed E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution). -- is the error I receive after trying removing libreoffice common –  Brenton Horne Jan 29 '13 at 20:03
    
@BrentonHorne: see my edit. –  Flimm Jan 29 '13 at 20:04
    
See my question edit (the resulting error was too long to fit in comments) –  Brenton Horne Jan 29 '13 at 20:08
    
@BrentonHorne: see my edit again. If they are any packages that depend on libreoffice-common, just remove them. –  Flimm Jan 29 '13 at 20:16

You can try removing the offending .deb file first:

sudo rm /var/cache/apt/archives/libreoffice-common_1%3a3.6.2~rc2-0ubuntu4_all.deb

Once that is done, update the list of available packages:

sudo apt-get update

Then proceed with running apt-get -f install, removing openoffice, etc.

share|improve this answer
    
Thanks, mate, I would try this if I could but Flimm solved it for me in chat. –  Brenton Horne Jan 29 '13 at 20:46
    
if you have a solution, please post it as an answer to your own question and (after a bit) mark it as the accepted answer. –  ImaginaryRobots Jan 29 '13 at 20:49
    
I'll let Flimm do so, I can't get credit for it, he can and he deserves it. –  Brenton Horne Jan 29 '13 at 20:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.