Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried to install Skype on my ubuntu 12.10 via command line

$ sudo apt-get install skype

I received this error :

The following packages have unmet dependencies:
libasound2-plugins:i386 : Depends: libasound2:i386 (>= 1.0.25) but it is not going to be installed
skype-bin:i386 : Depends: libasound2:i386 (>= 1.0.23) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

When I tried the suggestion,

$ sudo apt-get -f install

I get the following error :

Unpacking libasound2:i386 (from .../libasound2_1.0.25-3ubuntu3_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/libasound2_1.0.25-3ubuntu3_i386.deb (--unpack):
trying to overwrite shared '/usr/share/alsa/alsa.conf', which is different from other instances of package libasound2:i386
No apport report written because MaxReports is reached already
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
/var/cache/apt/archives/libasound2_1.0.25-3ubuntu3_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Configuration of my ubuntu is as follows :

$ uname -a
Linux sumitb-pc 3.5.0-21-generic #32-Ubuntu SMP Tue Dec 11 18:51:59 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Please help me out here ! :)

share|improve this question
    
the problem is that you updated your ubuntu. DO NOT accept all updates from ubuntu 12.04 or 12.10 and you will be OK. u must understand: skype belongs to microsoft now. they are putting out buggy versions so that you badmouth ubuntu and linux. –  tony gil Apr 17 '13 at 11:11

2 Answers 2

From this link, I entered

sudo add-apt-repository "deb http://archive.canonical.com/ $(lsb_release -sc) partner"

and then

sudo apt-get update && sudo apt-get install skype

I then got the same errors, which were fixed by entering

sudo apt-get -f install

and then retyping the 2nd command:

sudo apt-get update && sudo apt-get install skype

worked like a charm! You can now start skype by typing "skype" into the terminal, or searching for the application in Dash home.

share|improve this answer

For me it worked fine when i downloaded the package from Skype site and installed.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.