Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My optimal screen resolution is 1600x900px, however when I first turn on my laptop, grub2 displays at 1024x768. I have an optimus system, so I am assuming that grub is using the intel card. When I do vbeinfo it says the maximum resolution is 1024x768, but the optimal resolution is 1600x900. I have tried adding i915.modeset=1 to my grub config and changing GRUB_GFXMODE to 1600x900 but to no avail. All help would be appreciated!

share|improve this question
1  
I think that Grub doesn't support fancy high resolutions. It uses a fail-safe resolution. That way, if you spill coffee or something on your monitor, and you have to use a 'backup' monitor that only goes up to 1024X1280, it'll work, with a little margin of safety added, just incase. However, this is purely speculation. Do you really need to choose your OS in HD, though? –  JamesTheAwesomeDude Jan 30 '13 at 17:34

1 Answer 1

There's no guarantee that GRUB will be able to use exactly the same resolution your Xserver is running at with your video hardware. The only way to find out what settings will be acceptable here is to use GRUB to tell you. To find out, boot your computer and press your C key from your GRUB Menu to switch into command-line mode.

  • To prevent text from scrolling up the screen uncontrollably, first use the command set pager=1.
  • Then you can run the vbeinfo command for a list of resolutions your hardware can support.
  • Write the numbers down on a piece of scrap paper if you need to.

Now, let see how you can change change GRUB menu resolution:

  1. Open your /etc/default/grub file with a text editor and change your settings there: gksudo gedit /etc/default/grub.
  2. Alter the numbers after where it says"GRUB_GFXMODE=" with a suitable resolution for your hardware.
  3. Save the file before closing it.
  4. Run sudo grub-mkconfig -o /boot/grub/grub.cfg to write the changes to your grub.cfg.
  5. Reboot and see if it worked.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.