Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was able to run Sam 3 on nvidia card before. Now they added CS 1.6 but they changed paths. I modified the original command I was using for sam3 but it doesnt work.

cd ~/.steam/steam/SteamApps/common/Half-Life/ && 
    export LD_LIBRARY_PATH=~/.steam/steam/ubuntu12_32 && 
    primusrun ./hl_linux -game cstrike -console -dev -numericping -noipx

Its giving me this error:

Error:libsteam_api.so: cannot open shared object file: No such file or directory Could not load hw.so.

share|improve this question
add comment

1 Answer

After few hours I found it. You need to add game root path to the LD_LIBRARY_PATH:

cd ~/.steam/steam/SteamApps/common/Half-Life/ &&
export LD_LIBRARY_PATH=~/.steam/steam/ubuntu12_32:~/.steam/steam/SteamApps/common/Half-Life/ &&
primusrun ./hl_linux -game cstrike -console -dev -numericping -noipx

Also you need to be running Steam before you run the game.

Plus if you want to disable vertical sync you need to run

export vblank_mode=0

before running the game. So this is full bash script:

#!/bin/bash
export vblank_mode=0
cd ~/.steam/steam/SteamApps/common/Half-Life/ && export LD_LIBRARY_PATH=~/.steam/steam/ubuntu12_32:~/.steam/steam/SteamApps/common/Half-Life/ && primusrun ./hl_linux -game cstrike -nosync
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.