Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When Google Chrome opens, it displays a message that says that it "did not shut down properly". This happens everytime I open it, after booting the computer or just after closing the browser with the X. There is a button that offers me to open the recent tabs, but the button does not work and Chrome does not find anything, I end up on a blank page.

In order to solve my problems, I tried to turn off my extensions and that kind of things, but I found out that it does not work. Plus, the changes are not saved in Chrome apparently, I suggest that it is because it does not close properly.

I would like to solve this problem without removing and re-installing Chrome because I have a lot of stuff saved in my bookmarks and the configuration of my address bar*. The problem started out of the blue, not after any update or anything. I want it to be solved because I need to have access to my recently closed tabs when the browser opens.

I tried to update with the current stable version of Chrome but it did not change anything.

*Edit: my Address bar has search engines configured (maps, language translation, wikipedia...)

share|improve this question

2 Answers 2

up vote 0 down vote accepted

One of the possibilities is that your browser's profile has been corrupted. Without doing anything that could cause you to lose data, you could try making a new profile as described here: Create a new browser user profile in the section on Linux.

But, in short (although you should read the link above completely),

  • Make sure that Chrome is not running at all.
  • Rename ~/.config/google-chrome/Default to ~/.config/google-chrome/Default.bak.
  • Start Chrome. See if your problem is fixed.

Note that .config is a hidden folder. You'll need to enable viewing of hidden files and folders in your File Manager. Of course, if you use the command line, you could run something like:

mv ~/.config/google-chrome/Default ~/.config/google-chrome/Default.bak

If your problem is fixed, gradually copy over only files that you absolutely need (because some of them may be responsible for your problem in the first place) from Default.bak to the new Default folder that Chrome automatically creates.

Further, since you need your bookmarks, they are stored as a simple text file called Bookmarks in the Default folder so copying them over from Default.bak to the new Default should probably not break anything and give you back your bookmarks. Again, it's better to do this when Chrome is not running at all.

As for "configuration of my address bar", I don't know what that means. Perhaps you may want to edit your question to explain that aspect.

Edit: if you don't want to go the "new profile" route and if you have another Google account, you may try adding a new user. That option is available in chrome://settings. Do take look at the options which include importing stuff from another profile!

New User

share|improve this answer
1  
Thanks, I can not say that it worked because it kind of started working again by itself 24 hours later. But I had created a new profile at some point before that happened. –  MartinGalilee Jan 31 '13 at 7:28
    
This didn't solve my problem. I don't mind reinstalling chrome since I have everything sync with my Google account. I've delete my profile and created new ones, but I keep seeing this error. Any other ideas? –  Felipe Aug 19 '14 at 18:55

This was happening to me too and it was driving me crazy!

In my situation (trusty), this had nothing to do with user profiles. My issue was that the desktop environment was shutting down prior to the background chrome process; this caused chrome to 'ungracefully' exit and bug me about it with each restart.

Some of the solutions you find on line get around this by never letting chrome run as a background process, which was an unacceptable trade off for me.

I fixed it on my system by adding a stanza to the Upstart script for the desktop manager (Lightdm). You need to edit /etc/init/lightdm.conf as root and add the following at the end of the file:

pre-stop script
    pkill --oldest chrome
    sleep 2
end script

Hope this works for you!

share|improve this answer
    
I had to reboot twice before seeing this work. I believe editing the lightdm.conf file does not take effect until a reboot. –  Antonios Jun 23 at 12:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.