Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I created a bootable Ubuntu on my 32GB thumb drive (on a NTFS partition) and I selected a persistence of 4GB.

I've noticed that when I reboot from the initial booting off of the USB thumb drive, nothing is preserved. No apps that were installed nor saved bookmarks.

Is there a way for me to manually force persistence?

share|improve this question
    
what program have you used to create the persistent usb? –  cipricus Jan 28 '13 at 9:48

4 Answers 4

Be sure you have and always select "Persistent" option after booting from usb - if you do not see this option the usb has no persistence: it happened to me often for some reason. And to be sure that it works, I use, beside FAT32 (as stated in the other answer) a program called LiveUSB Install - here.

enter image description here

enter image description here

enter image description here

It provides a clear and nice interface for selecting the "persistent" boot (cannot give a screenshot of that) - it should be the second in the list after booting from live usb.

share|improve this answer
  1. List of "Related" questions on the right column might be helpful in solving your problem (e.g. making sure you have the boot option "persistent" in the configuration file)
  2. Instead of NTFS, FAT32 format might be more problem-free for Ubuntu live USB with persistence.
  3. Trying the Linux utility MultiSystem might work better in creating Ubuntu live USB with persistence: http://liveusb.info/dotclear/index.php?pages/install
share|improve this answer

Plug your USB into a computer running Linux or Windows.

If you used UNetbootin to make the persistent drive open syslinux.cfg. If you used Startup Disk creator open txt.cfg, (or text.cfg, depending on version).

You should see a line similar to:

append file=/cdrom/preseed/ubuntu.seed boot=casper persistent initrd=/casper/initrd.lz quiet splash noprompt --

If "persistent" is missing, add it.

share|improve this answer

I fixed my problem, but it was an unconventional way.

I gave up trying to get Ubuntu or Xubuntu onto a USB live drive due to the persistence issue so I went with Linux Mint (which is derived from Ubuntu). But I still used the same tool that I tried to make a live USB drive for Ubuntu and Xubuntu.

To answer Cipricus' question, the tool I used was the Pendrive Linux tool you can get here: http://www.pendrivelinux.com/universal-usb-installer-easy-as-1-2-3.

In hindsight, I don't know if the problem is with the Pendrive Linux tool or the latest versions of Ubuntu / Xubuntu but I solved my problem simply by trying a different distro.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.