Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

since I've installed Ubuntu I have problems with my touchpad. First under GNOME/Unity my touchpad was freezing for a couple of seconds with this dmesg-error:

psmouse serio1: TouchPad at isa0060/serio1/input0 lost sync at byte 1

(only with the touchpad/trackpoint but not with my USB-Mouse) Then some months later I changed from unity desktop to xfce-desktop & then to KDE: my touchpad AND trackpoint are either freezing for or are 'overreacting' (whole time till restart): When I touch the touchpad(AND trackpoint) it clicks everything with a right or leftclick and the cursor goes 'crazy'. dmesg:

psmouse serio1: TouchPad at isa0060/serio1/input0 lost sync at byte 1
psmouse serio1: TouchPad at isa0060/serio1/input0 lost sync at byte 1
psmouse serio1: TouchPad at isa0060/serio1/input0 lost sync at byte 1
psmouse serio1: TouchPad at isa0060/serio1/input0 lost sync at byte 1
psmouse serio1: TouchPad at isa0060/serio1/input0 lost sync at byte 1
psmouse serio1: issuing reconnect request
psmouse serio1: synaptics: device claims to have extended capabilities, but I'm not able to read them.
psmouse serio1: synaptics: device claims to have extended capability 0x0c, but I'm not able to read it.
psmouse serio1: synaptics: hardware appears to be different: id(149271-149271), model(114865-114865), caps(d047b3-d047b1), ext(b40000-0).
psmouse serio1: bad data from KBC - timeout

I cannot solve this problem with restarting xserver (login-logut), I must restart ubuntu to get the touchpad working.

But here my Xorg Log

[    37.683] (II) LoadModule: "synaptics"
[    37.683] (II) Loading /usr/lib/xorg/modules/input/synaptics_drv.so
[    37.683] (II) Module synaptics: vendor="X.Org Foundation"
[    37.684] (II) Using input driver 'synaptics' for 'SynPS/2 Synaptics TouchPad'
[    37.684] (II) synaptics: SynPS/2 Synaptics TouchPad: ignoring touch events for semi-multitouch device
[    37.684] (--) synaptics: SynPS/2 Synaptics TouchPad: x-axis range 1472 - 5888
[    37.684] (--) synaptics: SynPS/2 Synaptics TouchPad: y-axis range 1408 - 4820
[    37.684] (--) synaptics: SynPS/2 Synaptics TouchPad: pressure range 0 - 255
[    37.684] (--) synaptics: SynPS/2 Synaptics TouchPad: finger width range 0 - 15
[    37.684] (--) synaptics: SynPS/2 Synaptics TouchPad: buttons: left right double triple
[    37.684] (--) synaptics: SynPS/2 Synaptics TouchPad: Vendor 0x2 Product 0x7
[    37.684] (--) synaptics: SynPS/2 Synaptics TouchPad: touchpad found
[    37.684] (**) synaptics: SynPS/2 Synaptics TouchPad: (accel) MinSpeed is now constant deceleration 2.5
[    37.684] (**) synaptics: SynPS/2 Synaptics TouchPad: MaxSpeed is now 1.75
[    37.684] (**) synaptics: SynPS/2 Synaptics TouchPad: AccelFactor is now 0.036
[    37.684] (--) synaptics: SynPS/2 Synaptics TouchPad: touchpad found
[  8465.562] (--) synaptics: SynPS/2 Synaptics TouchPad: touchpad found
(EE) 3: /usr/lib/xorg/modules/input/synaptics_drv.so (0xb6326000+0xcf65) [0xb6332f65]
(EE) 4: /usr/lib/xorg/modules/input/synaptics_drv.so (0xb6326000+0x6c75) [0xb632cc75]
[  8625.425] (II) UnloadModule: "synaptics"

I'm using a Thinkpad L420 with Ubutnu 12.10. (New Kernel/all up to date.) I have tested a lot of things like set with gpointing-device-settings the lowest acceleration but I won't work for me.

Any ideas how to solve this problem?

share|improve this question

1 Answer 1

My Fix:

sudo touch /etc/pm/sleep.d/00_mousereset
sudo nano /etc/pm/sleep.d/00_mousereset

paste/type in the following and save:

#!/bin/sh

case "$1" in
        hibernate)
                ;;
        suspend)
                ;;
        thaw|resume)
                sleep 2
                /sbin/rmmod psmouse
                sleep 2
                /sbin/modprobe psmouse
                ;;
        *)      echo "ERROR calling " $0
                ;;
esac

sudo chmod 755 /etc/pm/sleep.d/00_mousereset

Save and next time you suspend/resume it should work.

share|improve this answer
    
Consider explaining why you think your answer will work. That will make people have more confidence in trying your suggestion. –  Magpie Apr 21 '13 at 3:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.