Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I did some trial on command line and creating a user account from it, then I logged off and logging to that newly created account (let us call it newaccount). Then I mounted one of my drive (I named it as LOSSProp) from it. After that, I returned to my account (myaccount), and then deleted newaccount. But then I lost my permission to mount mydrive and I can't open it anymore. Then I googling for a while, looking for a solution to fix it, I had tried

sudo chown -R username:username /media/mydrive

and using GUI by nautilus in sudo mode. But still I can't change its owner, it still owned by newaccount which I had deleted it.

How do I fix it?

share|improve this question
    
did you try this from within a root shell? $ sudo su - and # chown -R username:username /media/mydrive ? what kind of file system is that? –  vertoe Jan 27 '13 at 18:16
    
Your drive may still be mounted by newaccount. Reboot your machine in order to completely dismount all drives, and try again to mount your drive using Nautilus (you shouldn't have to use sudo or gksudo). –  Paddy Landau Jan 27 '13 at 19:09
    
I had rebooted my machine and the problem is solved.Thanks, all for give me some advices. –  heno72 Jan 28 '13 at 16:13
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.