This question already has an answer here:
Ubuntu version: up to date 12.04
I recently uninstalled Skype so that I could reinstall the most recent version; I was getting the "packages held back" message whenever I updated the software on my system and stupidly thought this was a good idea.
The result is that now I cannot get skype reinstalled because of broken packages/dependencies. I have tried installing the version I had installed (184.108.40.206.0-0ubuntu0.12.04.2) without success:
# apt-get install skype=220.127.116.11.0-0ubuntu0.12.04.2 The following packages have unmet dependencies: skype : Depends: skype-bin E: Unable to correct problems, you have held broken packages. # apt-get install skype-bin=18.104.22.168.0-0ubuntu0.12.04.2 The following packages have unmet dependencies: skype-bin:i386 : Depends: libqtwebkit4:i386 (>= 2.2~2011week36) but it is not installable E: Unable to correct problems, you have held broken packages.
The strange thing is that I have libqtwebkit4 version 2.2.1 installed:
# dpkg -s libqtwebkit4 (...) Status: install ok installed (...) Version: 2.2.1-1ubuntu4
How can I fix this situation? As far as I can tell I have a sufficiently recent libqtwebkit4 package installed yet apt won't let me install skype-bin.
Running aptitude search skype, I get:
pi skype p skype:i386 v skype-bin pB skype-bin:i386