Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

Ubuntu version: up to date 12.04

I recently uninstalled Skype so that I could reinstall the most recent version; I was getting the "packages held back" message whenever I updated the software on my system and stupidly thought this was a good idea.

The result is that now I cannot get skype reinstalled because of broken packages/dependencies. I have tried installing the version I had installed (4.1.0.20.0-0ubuntu0.12.04.2) without success:

# apt-get install skype=4.1.0.20.0-0ubuntu0.12.04.2
The following packages have unmet dependencies:
skype : Depends: skype-bin
E: Unable to correct problems, you have held broken packages.


# apt-get install skype-bin=4.1.0.20.0-0ubuntu0.12.04.2
The following packages have unmet dependencies:
skype-bin:i386 : Depends: libqtwebkit4:i386 (>= 2.2~2011week36) but it is not installable
E: Unable to correct problems, you have held broken packages.

The strange thing is that I have libqtwebkit4 version 2.2.1 installed:

# dpkg -s libqtwebkit4
(...)
Status: install ok installed
(...)
Version: 2.2.1-1ubuntu4

How can I fix this situation? As far as I can tell I have a sufficiently recent libqtwebkit4 package installed yet apt won't let me install skype-bin.

Running aptitude search skype, I get:

pi  skype 
p   skype:i386 
v   skype-bin  
pB  skype-bin:i386  
share|improve this question
add comment

marked as duplicate by Braiam, Stephen Myall, psusi, Eliah Kagan, Seth Aug 29 '13 at 15:26

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer

One thing I always try if I have problems with skype is to install a debian package from their site. If I remember correctly, it doesn't have the skype-bin dependency, but rather comes as a bundle.

Regarding your libqtwebkit4 problem, I think that you have the 64-bit version installed when skype requires the 32-bit version.

share|improve this answer
    
thank you for your reply! How can I install the i386 version of libqtwebkit4 for skype to be happy? When I try to install libqtwebkit4:i386 apt tells me that "The following packages have unmet dependencies: libqtwebkit4:i386 : Depends: libgstreamer-plugins-base0.10-0:i386 (>= 0.10.31) but it is not going to be installed Depends: libsqlite3-0:i386 (>= 3.5.9) but it is not going to be installed E: Unable to correct problems, you have held broken packages.". –  Sonia Bastclurd Jan 30 '13 at 21:51
    
Try installing the ia32-libs package and then running apt-get with the -f switch. –  Igor Zinov'yev Jan 31 '13 at 14:01
    
Trying to install ia32-libs produces: The following packages have unmet dependencies: ia32-libs : Depends: ia32-libs-multiarch E: Unable to correct problems, you have held broken packages. –  Sonia Bastclurd Jan 31 '13 at 14:46
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.