Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

On Ubuntu, I can choose between Edge scrolling, and Two-finger scrolling. But it's a radio button, so I have to choose between one and the other.

But is there any way to enable them both at the same time? Is this limitation because of the config GUI only?

enter image description here

share|improve this question
add comment

3 Answers 3

up vote 2 down vote accepted

To enable this permanently:

Create a file with the commands in mikewhatever answer:

echo synclient VertEdgeScroll=1 >> ~/.config/scroll-touchpad
echo synclient VertTwoFingerScroll=1 >> ~/.config/scroll-touchpad

We make it executable, and protect it from being deleted:

chmod +x ~/.config/scroll-touchpad
chmod -w ~/.config/scroll-touchpad

The we add to our gconf settings this file:

gsettings set org.gnome.settings-daemon.peripherals.input-devices hotplug-command '"'$HOME'/.config/scroll-touchpad"'

Now you can restart Gnome, log out and in, etc. and your preferences will persist.

Based on Nahuel answer

share|improve this answer
1  
Doesn't "chmod -x" cancel out the previous line? –  sashoalm Feb 26 at 20:28
add comment

You can use synclient VertEdgeScroll=1 to enable vertical edge scrolling,

or synclient VertTwoFingerScroll=1 for two finger scrolling.

Just copy/paste a command into a terminal window, and hit Enter.

So to have both just paste:

synclient VertEdgeScroll=1
synclient VertTwoFingerScroll=1
share|improve this answer
    
The commands are not persistent, it seems that this setting is being reset every time after I suspend and resume my laptop, and also when I reboot it, so I need to enter those commands again every time. –  sashoalm Feb 2 '13 at 7:52
3  
You are right, touchpad settings are reset on login by gnome-settings-daemon. You can try adapting this answer to your case. The command you'd use would be synclient VertEdgeScroll=1 VertTwoFingerScroll=1, or the two commands, as posted above, it doesn't matter. –  mikewhatever Feb 2 '13 at 10:09
    
Thanks, that worked –  sashoalm Feb 2 '13 at 16:52
add comment

Your problem is likely that your computer is recognizing your touchpad as a mouse. Run this command and insure the touch pad is seen as "EPTS/2", not "PS/2".

xinput list

The solution is found at:

http://superuser.com/questions/721417/elantech-touchpad-recognized-as-ps-2-mouse-ubuntu-13-10

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.