Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I watch a film with subtitles in either VLC or other movie players, the subtitle isn't as clear as on Windows.

It's thin and seems to be grayed out, whereas in VLC on Windows I have a clear white subtitle (I checked the settings for VLC subtitles in both Windows and Ubuntu and they are identical).

I am using Arial, and first I thought it was the font because it wasn't included in the Ubuntu default, so I changed it with no results.

Screenshots:

Ubuntu:
Ubuntu

Windows:
Windows

I have no idea how to make subtitles work. I am planning to switch to Ubuntu for good, but there are many detail problems like this that really make my movement hard.

share|improve this question
1  
Welcome to askubuntu! Please edit your question to focus on one problem alone. Then ask multiple questions for each problem and you will be helped. If you change the title to 'VLC subtitles blurry' and drop anything personal, your mileage may increase a lot. –  aquaherd Jan 27 '13 at 11:22
    
Thanks for your suggestions.. I have edited the title and deleted the facts that don't have to do with it. –  Alexandru Beșe Jan 27 '13 at 12:22
    
If I am reading your question right, I think your issue is about the upscaling quality of the subtitle texts, which seems indeed to be very low from your screenshots. I am not able to reproduce this, all looks very well on subtitled low-resolution video put on full screen. Please elaborate more on the 1) subtitle settings, 2) video output settings, 3) font rendering engine, 4) the type of video, 5) the type of subtitles (Menu Tools -> Codec information), 6) the version of Ubuntu and 7) VLC. –  gertvdijk Jan 27 '13 at 15:32
    
I still haven't found a solution to this, and tried a lot of things.. i really don't know how to get this rendering done properly.. –  Alexandru Beșe Jan 30 '13 at 20:33
    
@user126477 Well, I've requested a lot of information for a reason... We need that in order to have it answerable. Keep in mind that we don't have your hardware, we don't have that video you play there, we can't see your screen, etc. We rely on the information you're providing in your question. –  gertvdijk Feb 1 '13 at 22:42

1 Answer 1

up vote 9 down vote accepted

In VLC go to Tools-Preferences -> Video -> Output: and change it from default to x11 video output (XCB).

share|improve this answer
    
Thanks a lot ! This solution worked as a charm ! –  Alexandru Beșe Feb 2 '13 at 20:21
    
@Alexandru Beșe: let's up-vote this excellent answer! (and it's the only one on askubuntu). –  cipricus Mar 15 '13 at 9:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.