Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I had an issue with my realtek network drivers and r8168. So I followed many guides on how to fix this and I installed and compiled the latest drivers from realtek, however, in the end I still had the same issues. My problem now is that the driver is totally screwed somehow. I tried re-installing it, tried taking in on and off the blacklist but it seems nothing I try works.

So I need a way to completely reinstall and reconfigure the network in ubuntu. If I can uniinstall the network component (Lan cable / ipv4) and reinstall it that would be great.

Any ideas ?

bte - I'm using a 3G connection for the meanwhile.

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

This depens on what exactly did the realtek-driver so to your system.I guess the driver did install itself into the modules directory of your kernel. In this case you can reinstall the kernel:

sudo apt-get install --reinstall linux-image-$(uname -r)

Another option is that the driver did install itself into the update-directory in the kernel:

/lib/modules/$(uname -r)/updates/...

Here you can simply delete the module from that directory.

To find out where the driver is located use:

modinfo "Name of the kernel module"
share|improve this answer
    
Thx , this worked. To be honesy , my kernel was on 35 so I updated to 37. I still have an issue with the driver not working as it should but at leasy my internet is working. Im thinking of installing a non realtek network card. –  Janpan Jan 28 '13 at 11:27
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.