Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Hi I want to boot Ubuntu quantal to a command prompt always and then use startx to launch x-windows if required. I have used the following methods but none work correctly.

  1. update-rc.d -f lightdm remove ---- does not work in quantal, works in debian sid.

  2. I used the boot paramter 'text' on the grub command line. This does boot to console but then when I do startx only starts the server - no clients, if I do startx gnome-shell then gnome-shell runs but a lot of the initialisation is not done.

  3. I also used start lightdm (after using the 'text' boot parameter). The problem is x starts with clients ok, but then when I exit X the server does not shutddown.

I would like to boot to a command prompt use startx to start gnome shell fully initialised, then on exit the x server should shutdown. I can do it fine in debian sid, ubuntu 12.04 but not ubuntu 12.10. Any help with quantal would be greatly appreciated. Thanks, Rob

share|improve this question

2 Answers 2

No lightdm is the display manager, but as i said above update_rc.d -f lightdm remove does remove all the links but it still boots into x windows. This procedure works on my debian sid system but not in ubuntu 12.10. Canonical have obviously done something that does no use those sysvinit links. Thanks for your help. Rob

share|improve this answer

You should disable GDM, the GNOME Display Manager:

sudo update-rc.d -f gdm remove

When you restart your computer, you’ll be presented with a text-mode login prompt instead of the graphical environment.

Run X.Org:

If you want to run the graphical environment, all you have to do is type the following command from the prompt, making sure to run it as your normal user account.

startx

Enable X.Org:

sudo update-rc.d -f gdm defaults
share|improve this answer
    
Thank you, I thought the display manager was lightdm but I guess this uses gdm. I will give it a try. Thanks so much. –  user91119 Jan 28 '13 at 17:12
    
Hi I have just tested it but it does not work. I did update-rc.d -f gdm remove. It reported all links gdm removed when I rebooted it has booted straight back into x windows. But in any case I thought the display manager was lightdm. Is there anything else I can try besides the 'text' boot parameter in grub2? –  user91119 Jan 28 '13 at 17:35
    
is gdm installed on your system? –  1linecode Jan 28 '13 at 18:00
    
@user91119 You were right initially. Ubuntu uses LightDM (unless you're using a quite old version of Ubuntu). Not GDM. (GDM is available if you want to use it, but LightDM is the default display manager.) –  Eliah Kagan Jan 29 '13 at 7:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.