Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have G++ 4.7.2 on my Ubuntu 12.04 and I'm trying to install 4.8.

I downloaded the file from the GNU repository.

After configure and make, I get the following error:

collect2: error: ld returned 1 exit status
make[3]: *** [build/gengtype] Error 1..

etc.

Is there ANY way to install 4.8 on Ubuntu?

share|improve this question
    
these details will not be enough . we need more log . –  AgentCool Jan 27 '13 at 0:52
    
You say "etc.", please elaborate and paste the full error message here. –  user98085 Jan 27 '13 at 1:23
1  
Uhm, 4.8.0 hasn't been released yet (at the time of writing). It's still in development... GNU GCC releases page. So please elaborate more on where you got this copy and why you need a development version (you probably don't). –  gertvdijk Jan 27 '13 at 1:34
    
Why is this duplicate of How to install gcc-4.8 in Ubuntu 12.04 from the terminal? g++ and gcc are different packages! –  Radu Rădeanu Sep 14 '13 at 12:37
    
@RaduRădeanu you are probably right in view of the fact that the ppa shown there does not provide g++-4.8, but it also describes how to build the package from source. –  guntbert Sep 14 '13 at 15:36

1 Answer 1

For the moment g++-4.8 doesn't exist in Ubuntu repositories since is still in unstable or testing version and also there is no any PPA from where you can get g++-4.8 (even if you can find in other places that can be found in https://launchpad.net/~ubuntu-toolchain-r/+archive/test - check the link and you will see that is not there). But it can be found in Debian repositories. Depending on your system architecture, download:

More about: http://packages.debian.org/sid/g++-4.8, http://packages.debian.org/jessie/g++-4.8 (you should check also the dependencies).

share|improve this answer
    
Could you please elaborate on what we do with the downloaded file? Thanks –  mezamorphic Nov 3 '13 at 22:49
1  
@mezamorphic You have to install it. Just double click on it. –  Radu Rădeanu Nov 4 '13 at 6:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.