Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So I thought I had finally solved my woes about Cinnamon glitching out (occasionally) when trying to run full-screen games. I set up an alias for 'sudo service lightdm restart; sudo startx'. It worked a few times when something crashed or glitched and I had to ctrl+alt+f2. But now I seem to have screwed something up, because trying to log in from the lightdm login screen on 12.04 shows a familiar screen with some weirdly indented text, and then kicks me back to the login screen without explanation. I've tried removing ~/.Xauthority and then doing the same command as above, but that didn't work. Good thing I left the guest account enabled.

Any suggestions?

Shows what I get for mucking around with things I don't fully understand. But I'll try to learn from this.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Turns out I was only using the wrong command. When I deleted ~/.Xauthority, I needed to next run sudo service lightdm restart, without using startx. A learning experience indeed.

share|improve this answer
    
so issue gone ? –  AgentCool Jan 27 '13 at 0:55
    
Yup, it's just vanished. –  ssonicblue Jan 29 '13 at 23:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.