Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I cannot find the drivers for AMD Radeon HD 7730M(Dell Inspiron 15R Special Edition) on the AMD website! can someone please send me the link to download any open source drivers if available?

Also the fan doesn't stop running when booted into ubuntu (not the case with windows8). Any solutions??

Thank you...!

share|improve this question
    
AMD.com>Support & Drivers>Select Product>Select OS>Get link.. it works. –  Uri Herrera Jan 26 '13 at 23:36
    
askubuntu.com/questions/192381/… You may find good information at this link –  oliver.prado Feb 2 '13 at 18:54
    
With my Inspiron 15r 7520 with my ATI Radeon hd 7730m. I end up getting put in fallback mode when installing the driver on my Linux Mint 14. –  user143371 Mar 25 '13 at 21:23

4 Answers 4

http://support.amd.com/de/gpudownload/linux/Pages/radeon_linux.aspx

This is the link for the radeon driver!

And about the fan, you can try this solution.

https://answers.launchpad.net/ubuntu/+question/204193

share|improve this answer

Ubuntu 13.10 now supports Hybrid Graphics. If you have Ubuntu 13.10 and Radeon hybrid graphics you can install the driver and catalyst control center as easy as follows:

sudo apt-get install fglrx fglrx-pxpress

Then your fan problem and driver issues will be gone. And after you can start Catalyst Control Center and switch your graphics card. You can start catalyst control center in dash by shortcut or through terminal as follows:

sudo amdccle

--remember to run Catalyst Control Center as root to switch graphics--

PS:

I really don't know whether above works with Ubuntu 13.04 or earlier. For those old systems you can just turn off the discrete graphics card (ATI Radeon Graphics card) to solve overheating, fan issue and increase battery life.

You can just turn off ATI card as follows:

chmod -R 705 /sys/kernel/debug
chown -R <yourusername>:<yourusername> /sys/kernel/debug/vgaswitcheroo # replace <yourusername> with your username.
echo OFF > /sys/kernel/debug/vgaswitcheroo/switch

You can then add the 3rd command into /etc/rc.local file before exit() command so that it executes everytime when system starts. This also worked for me in Ubuntu 13.04.

share|improve this answer

In addition to @Deepal's comment - you also would want also edit your GRUB file with one line in GRUB file /etc/default/grub

old:

GRUB_CMDLINE_LINUX=""

fix:

GRUB_CMDLINE_LINUX="quiet splash nomodeset"

Save and exit and proceed accordingly as per above's suggestion.

source: [link] ATI Radeon HD 6750 Ubuntu 13.10

share|improve this answer

About the fan, same laptop here.

Try installing the i8kutils package

http://ubuntuforums.org/showthread.php?t=842775

Then use i8kmon

http://manpages.ubuntu.com/manpages/gutsy/man1/i8kmon.1.html

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.