Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Is there a way to easily turn on/off showing the boot messages (loading the services) when Ubuntu starts? Is it something in Grub2?

I am running Lucid.

share|improve this question
add comment

5 Answers 5

up vote 23 down vote accepted

You would need to edit the file /etc/default/grub. In this file you'll find an entry called GRUB_CMDLINE_LINUX_DEFAULT. This entry must be edited to control the display of the splash screen.

The presence of the word splash in this entry enables the splash screen, with condensed text output. Adding quiet as well, results in just the splash screen; which is the default for the desktop edition since 10.04 (Lucid Lynx). In order to enable the "normal" text start up, you would remove both of these.

So, the default for the desktop, (i.e. splash screen only):

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

For the traditional, text display:

GRUB_CMDLINE_LINUX_DEFAULT=

After editing the file, you need to run update-grub.

sudo update-grub

Edit:

For more details, see this: https://help.ubuntu.com/community/Grub2

share|improve this answer
    
How can you read that messages that are shown after you removed the splash from GRUB_CMDLINE_LINUX_DEFAULT? I can see the messages now when I start, but then X starts and they are gone. –  rubo77 Mar 31 at 12:00
add comment

I may be out of subject, but you can just press "escape" during boot, to show/hide the plymouth splash screen...

share|improve this answer
    
By "easily turn on/off", I think it's just what he/she wants. –  Rodrigo Carvalho Jul 29 '10 at 11:01
    
Does that work on 10.04? –  Jim Jul 29 '10 at 13:51
    
Yes. I actually tested it on both Lucid Lynx Desktop and Netbook editions before posting :-) –  Little Jawa Jul 29 '10 at 13:54
3  
It works only if grub is not quiet, i.e.: GRUB_CMDLINE_LINUX_DEFAULT="splash" –  sup May 15 '11 at 9:01
add comment

There's a simple way of hiding all boot messages. In /etc/default/grub, adjust the following:

GRUB_TIMEOUT=0 # Do not show the GRUB menu at all
GRUB_CMDLINE_LINUX_DEFAULT=quiet
GRUB_CMDLINE_LINUX="console=tty12" # Redirect the kernel output to another tty

After that, just sudo update-grub, and it should be done.

share|improve this answer
add comment

You didn't identify whether you are on a server system or desktop, so I'll address both.

If you add splash to /etc/default/grub/ in GRUB_CMDLINE_LINUX_DEFAULT, Ubuntu will present you with a splash screen, either a simple text based progress bar or graphically via plymouth, which I describe below.

Using plymouth, a graphical startup animator, you can provide a pretty bootscreen that is well suited to desktop machines. You might not want to do this on a server, but it's up to you.

sudo apt-get install plymouth-theme-ubuntu-logo
share|improve this answer
add comment

I use GRUB_CMDLINE_LINUX_DEFAULT="noplymouth" to tell my laptop to not show me the startup picture but the boot messages … still works for 11.10

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.