Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed Ubuntu 12.10 on my PC, and it grabbed an IP address that the network doesn't like. I have tried to change it, but to no effect. If anyone could tell me how to do this, I would be very very grateful.

I think the problem is in the route, but I have no idea what I'm doing with Internet Protocol.

Note: I know the network works, I had Kubuntu on my PC before, but it erred out because I installed an incompatible program. (Didn't know, my fault) Anywho, it connected on Kubuntu, and now it doesn't want to.

share|improve this question
2  
Can you clarify what's "default IP", and why you think the "network doesn't like" it. Usually, a router hands out IPs (so what's not to like), and Ubuntu has nothing whatsoever to do with that. –  mikewhatever Jan 26 '13 at 20:36
    
@mikewhatever please s/router/DHCP-Server/ :-) –  guntbert Jan 26 '13 at 20:39

2 Answers 2

Ubuntu doesn't "grab" an IP address. It gets handed whatever IP address a DHCP server (usually on your home router) gives it.

share|improve this answer

Your IP isn't usually "selected" by Ubuntu. It is usually given to it by the router, or remote system (ISP / datacenter), and in the very rare cases of virtual machines, you have to configure that on the system that's hosting the vm (since that's how the VM gets the IP).

You can't change the "default" ip, because as i said above, the IP isn't "selected" by Ubuntu, its handed to you from a location somewhere upstream in the network from your computer (whether its from the router, or ISP). (therefore, there is no "Default" IP address)

Unless both myself and Dennis (the other answerer) are misunderstanding what you're wanting to do, you're likely going to get this same answer from more than just us.

share|improve this answer
    
Never mind, I fixed it. The DNS handed my computer the IP address for my mother's laptop. (Not sure why), so logging in from the laptop to post this disabled my PC's ability to connect, which was inactive at the time. The network is technically not DHCP enabled, so it shouldn't have given an IP, anyway, which is why I thought it had been randomly generated upon install. Changed the network settings over to manual, punched in the IP my network admin gave me, and rebooted, fixed the problem. Also, I changed the route to match the IP for the DNS router, not sure it matters, but hey, it works. –  user126344 Jan 26 '13 at 22:06
    
Your router would give it an IP address, whether you have DHCP enabled for your connection or not - you have to tell it to do static for that system usually, otherwise it causes conflicts :P –  Thomas W. Jan 27 '13 at 3:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.