Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was having problems reading all files on an extra hard drive so I attempted to "fix" this with these commands as root:

chown dave:dave /media/250GB
chmod 644 * /media/250GB

I'm now unable to see the drive and mount it in my Nautilus shortcuts and I need to go into NautilusFile Systemmedia250GB to see my files. I had two folders in the drive both with backed up data, but both folder now show as files which Nautilus doesn't know what to do with them (it doesn't treat them as folders).

ls -l reports:

...:/media/250GB$ ls -l
total 8
drwxr-xr-x  4 root root 4096 2013-01-23 19:24 2013-HOME-BACKUP
drwxr-xr-x 11 root root 4096 2013-01-23 19:22 2013-WORK-BACKUP
share|improve this question
    
Since I had some files transferred from the 250GB drive to my Desktop I decided to run those two commands on my Desktop folder and subdirectories. I get a "ERROR : Permission Denied" note now when trying to move or open files that are on my Desktop! –  I Heart Ubuntu Jan 26 '13 at 18:37
    
paste.ubuntu.com/1574126 –  I Heart Ubuntu Jan 26 '13 at 22:04

1 Answer 1

up vote 1 down vote accepted

OK, I fixed my 250GB drive by running this command...

sudo chmod 775 /media/250GB -R

...and I fixed my Desktop permission problems by running this...

sudo chmod 775 /home/Desktop -R
share|improve this answer
    
755 is OK for directories, but it will make all files executable! 664 is the default permission for files. –  Andrea Corbellini Jan 27 '13 at 19:19
    
for some reason though, unknown to me, 644 wasnt working and permissions were not being changed. After reboot everything still works. –  I Heart Ubuntu Jan 27 '13 at 19:23
    
644 is not OK for directories. You applied 644 to a directory, that caused your problem. However now you have applied 775 mode to files too, not just directories. The -R option means "recursively descend all files and directories". So yes, you have fixed the problem with your directory, but you have introduced a problem with your files. –  Andrea Corbellini Jan 27 '13 at 19:27
    
Ahhh. I see what you mean. If I click a TXT file it tries to run it in terminal. Do you know how do I fix this new issue? –  I Heart Ubuntu Jan 27 '13 at 21:09
    
find ~ ! -type d -exec chmod 664 {} \; should do the trick. –  Andrea Corbellini Jan 27 '13 at 21:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.