Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Whenever I give someone a .odt file created with LibreOffice and they open it with Microsoft Word, it says that the file is corrupt. Is there a CRLF problem or are the .odt files MS Word makes and the .odt files LibreOffice makes different altogether?

I'm trying to promote using .odt files (there's an xkcd comic on this :P) but it seems as though Microsoft doesn't want that to happen. Is there a way to make sure that my .odt files will not appear corrupt to Microsoft Word?

share|improve this question
I'm pretty sure that LibreOffice produces more standard ODF files than Microsoft's software. Are you sure you've saved and transferred the file correctly? Verify the hash (MD5/SHA) on both ends to be sure. Anyway, is it this what you're talking about? – gertvdijk Jan 26 '13 at 18:07… – Mateo Jan 26 '13 at 21:15
@gertvdijk The file is transferred correctly; yes that's it. – Vreality Jan 26 '13 at 22:32
@mateo_salta That's not what I'm talking about. – Vreality Jan 26 '13 at 22:32
What LibreOffice version are you using? If it's 3.6 and you're sending ODF files to users of Office 2010 this seems not to be compatible. LO 3.6 uses ODF format 1.2 for which you need a newer Office version. – gertvdijk Jan 26 '13 at 22:45
up vote 7 down vote accepted

Microsoft office 2010 does not support ODF 1.2 format, which LibreOffice does. If you change the ODF format used in LibreOffice to 1.0/1.1 you will no longer have this problem.

share|improve this answer
That makes more sense now (in an odd, M$ sort of way). – Vreality Jul 30 '13 at 2:55
I found the settings in Libreoffice 4.2 for this in Options under 'Load/Save', in the 'Default file format and ODF settings' – Wilf Jun 17 '14 at 17:30

In my experience, MS Word 2010 does, in fact, open .odt files, even though it gives two error messages first. If I send people an .odt document, I just ask them to ignore the error messages.

Or at least Word 2010 running on Windows 7 does so. The Apple version of Word seems to have further problems.

If sending an .odt document, I do offer to send it in another format (such as .docx) if required. But it helps make people aware of the Open Document format. A link to can help.

share|improve this answer
+1 for the good link to share. – Vreality Mar 1 '13 at 21:34

This seems to be a problem with MS Word and not Libre Office. For now, I guess I'll have to stick with .doc, .docx, or .html.

share|improve this answer

because Microsoft does not support .odt files. in Word 2010 does not even open .odt files. at least not on my laptop. There fore I would just Save it in LibreOffice as .docx file

share|improve this answer
Well, you can save a file as .odt in MS Word so I don't see why they wouldn't support opening it. – Vreality Jan 26 '13 at 22:34
This answer is just not true. – gertvdijk Jan 26 '13 at 22:34
@gertvdijk Thank you. I was having trouble finding a source. :) – Vreality Jan 26 '13 at 22:38
I have 2008 on mac and it doesn't open .odt, yet i found this article saying you could for 2007… – Mateo Jan 26 '13 at 22:50
@Vreality I am guessing it will be a very long time (if ever) before MS decides to allow opening of non-proprietary formats on MS Word. I would suggest when sending the file, say in the email... or whatever way you are sending it, that they will have to use Libre Office... it is avalible at (provide the link) and it's free! I have gotten a few people to switch. – pgrytdal Feb 6 '13 at 7:44

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.