Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This was not my first time attempting dual boot, but it is for doing this with Windows 8. The troublesome UEFI does not detect my USB stick although I changed the boot order and disabled secure boot. Then I changed to Legacy BIOS, it now detects the USB stick and I can boot into a live session, but it is still useless as Windows 8 needs to boot using UEFI and automatically I have to install Ubuntu as UEFI too, but there is no such option since I am using Legacy BIOS. So I tried to install Ubuntu using Legacy BIOS (thought of switching between UEFI and Legacy BIOS when I want to switch OS), but when I restart, I can't boot into Ubuntu at all, it always states "Please insert removable media and..."...Any possible workaround for this? It is kinda important as I have projects to be done using Ubuntu.

**Note: I am running Acer Aspire V3-571G. Made a Live USB Stick using ubuntu-12.04.1-desktop-amd64.iso

share|improve this question
    
possible duplicate of Installing Ubuntu on a Pre-Installed UEFI Supported Windows 8 system –  Ringtail Jan 26 '13 at 21:39

1 Answer 1

Ok, found the problem. The Live USB I created was not EFI compatible (i.e. no files/folders in /boot/grub that have "efi" in the name). So I what I did was simply re-creating the Live USB within Ubuntu on another laptop using the Startup Disk Creator utility. Previously, I made the Live USB using Universal USB Installer (did it with Windows) which does not create the "efi" files at all. Now, my Live USB is detected and I just dual booted Windows 8 and Ubuntu 12.04 (with secure boot disabled of course).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.