Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running Ubuntu 12.04 64bit at the moment, however, I have been experiencing the problem since about 11.04. (Tried 32 and 64bit versions)

My problem is that when browsing the internet, pages really struggle to load. Sometimes they load fast without any problem. Other times, they time-out and I have to refresh the page a couple of times before the page loads. Sometimes, even if the page starts loading, it does not load the entire page.

For example, sometimes, it will not load css for a page and the entire page will just be plain html. Other times, pictures and other embedded content fail to load. It has come to the point where I have installed a plug-in for Firefox to auto refresh my pages. Usually, it takes about 7 seconds of refreshing before the page starts loading, and that’s if it completes the loading.

Sometimes, certain applications have similar symptoms. For example, when using apt-get in the terminal to install or update, it sometimes fail to connect to sources and I have to try again until it connects.

Here are some facts and things I have tried regarding the problem:


  • I have no connection problems in Windows. (Windows XP, Windows Vista, Windows 7)
  • Using a different connection works without a problem. (Used a mobile 3G connection)
  • I have tried using different browsers. (Firefox,Chromium)
  • I have tried a different Network manager. (Wicd if I remember correctly)
  • I have set the time-out time to 100. (sudo sysctl net.ipv4.tcp_fin_timeout=100)
  • My installation is up to date.
  • I have no problem when downloading files. (Once a download starts, there is no problem.)

I have spoken to my ISP and they said everything is fine from their side and besides, my internet works without any problem in windows.

I would really like if it worked in Ubuntu as it is my primary operating system, but you can understand how frustrating and unproductive it can be when your web pages times out all the time. Please help.

T.I.A.

EDIT 1:

enter image description here

If that image is difficult to read, http://i47.tinypic.com/2r5f22u.png

http://i46.tinypic.com/1zw2rgj.png

http://i48.tinypic.com/2ccml8j.png

http://i49.tinypic.com/j7yxw9.png

EDIT 2:

http://i47.tinypic.com/qx1mvc.png

enter image description here

share|improve this question
    
What are your DNS settings under Windows and under Linux? What is the status of IPv6? I see you mentioned an ipv4 setting, so I suppose you're using at least that, are you also using ipv6, or is ipv6 enabled under Windows and under Linux? –  njsg Jan 26 '13 at 13:47
1  
"Once a download starts" -> This is a sign that you have some DNS issue, my bet would be that some bogus server is getting into the list (while it doesn't under Windows) or that you're getting a server which provides ipv6 addresses too and you've got ipv6 disabled under Windows. –  njsg Jan 26 '13 at 13:48
    
Please share some error messages of when stuff times out, especially apt-get and simple programs like wget; Also, do your browsers show any error message? –  njsg Jan 26 '13 at 13:49
1  
@Janpan what's the output of host archive.ubuntu.com and traceroute 91.189.92.201? I see you are getting ipv6 addresses from DNS, but you seem to have other network issues, it's not because of these ipv6 addresses. If possible, just copy the output of the commands (select, then middle click), no need to take screenshots. As you say Windows has no issues, it would be interesting to know the routes set in Windows (but I'm no windows expert, no idea on how do you check that). –  njsg Jan 26 '13 at 14:41
1  
@Janpan I will stop here because I have no exact idea of what is going on, my searches so far find that there were (are?) issues with the kernel drivers for RTL8111B, I wonder if that affects RTL8111C, this may mean you may need to install realtek's own drivers, I wonder if ubuntu has a package for that. Or maybe the wrong driver is being loaded, I'd give rmmod r8169 followed by modprobe r8168 a try. If the module does not exist, or if it does not create a network interface, just reverse it (that is, run rmmod r8168 followed by modprobe r8169). None of this will survive a reboot. –  njsg Jan 26 '13 at 15:12
show 13 more comments

1 Answer 1

Two suggestions:

  • In 12.04, here were changes the way DNS lookup was done (http://www.stgraber.org/2012/02/24/dns-in-ubuntu-12-04/). You can disable dnsmasq as described in the above article and try.

  • Try another modem: I had the same problem. I use ADSL connection with wireless router. Pages load perfectly with 3G modem, but load slowly with ADSL modem + wireless router. I tried with a different ADSL Modem from my friend and it worked perfectly with my Linux mint 13 (based on Ubuntu 12.04).

share|improve this answer
    
Planning to post this as a comment, but posted as answer :( If someone can make this a comment, that would be appropriate. –  banavara Feb 21 '13 at 6:47
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.