Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Whenever I attempt to play a video (or an audio file) with Totem I get the following error:

totem invalid commandline The parameters passed to the application had an invalid format. Please file a bug!
The parameters were: --transient-for=75497483 gstreamer|1.0|totem|H.264 decoder|decoder-video/x-h264, level=(string)3, profile=(string)high, stream-format=(string)avc, alignment=(string)au, parsed=(boolean)true

I've added the gnome3 team's PPA if that matters.

share|improve this question

3 Answers 3

I ran into the same problem as you did. So I tested my video playback (mp4, h264) with VLC and it worked very well. But I wasn't able to have Quicktime playback in Firefox with the mozilla-plugin-vlc and browser-plugin-vlc.

So my advise to you would be to use mplayer with gecko-mediaplayer. This solves all my problems.

share|improve this answer

This solve my problem.

sudo apt-get install h264enc

will install H.264 in your system.

share|improve this answer

I had this problem for awhile on debian. The solution was to install some recommended packages of totem. gstreamer1.0-libav helped there.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.