Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using Wine 1.5.17 on Ubuntu 10.04 LTS. The installation was finished successfully. I clicked the audio tab to configure audio, but it says Selected driver:(None). I can't even change the driver. When I click Test Sound button no sound is heard. Here is a screenshot:

screenshot of WIne Audio Tab

The error I got when clicking Test Sound button was:

err:ole:CoInitializeEx Attempt to change threading model of this apartment from multi-threaded to apartment threaded
err:mmdevapi:DllGetClassObject Driver initialization failed
err:ole:apartment_getclassobject DllGetClassObject returned error 0x80004005
err:ole:CoGetClassObject no class object {bcde0395-e52f-467c-8e3d-c4579291692e} could be created for context 0x1

How can I fix this sound problem?

share|improve this question
add comment

4 Answers

up vote 1 down vote accepted

The problem was solved. I had a 1.5.17 source code version of wine. I uninstalled the source code version and installed the default 1.2 version for lucid and the sound works now. So I guess the solution is check for other wine versions in your system and remove it and install a version that is suitable for your computer.

share|improve this answer
add comment

It's likely that you're missing some dependencies. Another wine user seemed to be having the same issue, and it was suggested they install the libasound2-dev package, although they were using Linux Mint, so that may or may not help.


The following two methods I found on the Wine Wiki, on a page about building Wine, so they might not work for an already-built

The Ubuntu-specific method seems to be to run sudo apt-get build-dep wine1.5 in a terminal.

However, according to the Wine Wiki, the easiest way to install all the correct dependencies is to download and run this script as root (e.g. with sudo). (Note: To save the script, either copy paste it into a notepad, or just right-click on the link and click "Save link as".)

Then, in terminal run sudo sh ./install-wine-deps.sh.

share|improve this answer
add comment

Run the following commands to get pulseaudio working with wine:

sudo add-apt-repository ppa:ubuntu-wine/ppa
sudo apt-get update
sudo apt-get upgrade

This will update Wine to a version that supports pulseaudio. Once you have done that, open winecfg and select PulseAudio Driver under Sound Drivers.

Go to WebUpD8 for a complete tutorial on getting pulseaudio to work with wine.

share|improve this answer
    
I can't download wine again because it exceeds 100 MB and my internet connection is slow –  Subin Jun 29 '13 at 6:33
add comment

I don't know if my answer makes sense, but I had the same issue ( Debian 3.2.51-1 64 bit, Wine 1.4.1 ) I stacked for a couple of days looking for the solution. But it was pretty simple:

sudo apt-get install libwine-alsa
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.